HDMI Audio Setup Issues and Solutions - Page 2 - Home Theater Forum and Systems - HomeTheaterShack.com

 1Likes
Reply
 
Thread Tools
post #11 of 15 Old 09-04-16, 09:11 PM
Shackster
 
etc6849's Avatar
etc6849
 
Join Date: Jan 2009
Posts: 91
Re: HDMI Audio Setup Issues and Solutions

Hi, I am using Intel HDMI audio setup to 5.1 (side speakers) in Windows 7 Ultimate, not set as default. I am also using Dirac, setup to 5.1 and default. Dirac Audio Processor will show 2 channels 44.1kHz, while the XMC-1 will still show 5.1, but will show 44.1kHz.

When I play stereo using Wasapi Dirac in foobar or Kodi, my XMC-1 shows 5.1! When I try mutlichannel, my XMC-1 shows 7.1!?!

Any ideas? Does your Dirac setup automatically change the number of channels properly?

PS: When I use Wasapi using Intel HDMI audio (instead of Dirac WASAPI), the number of channels change properly (XMC-1 shows PCM 2.0 for stereo).

Quote:
AudiocRaver wrote: View Post
Another little update, concerning use with REW.

Last edited by etc6849; 09-04-16 at 09:17 PM.
etc6849 is offline  
Sponsored Links
Advertisement
 
post #12 of 15 Old 09-07-16, 04:08 PM Thread Starter
HTS Moderator
Reviewer
 
AudiocRaver's Avatar
Wayne Myers
 
Join Date: Jun 2012
Location: Lincoln, NE
Posts: 4,836
Re: HDMI Audio Setup Issues and Solutions

Quote:
etc6849 wrote: View Post
Hi, I am using Intel HDMI audio setup to 5.1 (side speakers) in Windows 7 Ultimate, not set as default. I am also using Dirac, setup to 5.1 and default. Dirac Audio Processor will show 2 channels 44.1kHz, while the XMC-1 will still show 5.1, but will show 44.1kHz.
My setup is Dirac in the PC/server, and it does not show frequency or channels, only that it is streaming. All is set to 5.1 throughout, with foobar as the player, and the Onkyo AVR always says Multichannel, even with stereo source.

Quote:
When I play stereo using Wasapi Dirac in foobar or Kodi, my XMC-1 shows 5.1!
That is what I see in my AVR.

Quote:
When I try mutlichannel, my XMC-1 shows 7.1!?!
That is a mystery!

Quote:
Any ideas? Does your Dirac setup automatically change the number of channels properly?
Not really, it does not change at all. MUltichannel all the time.

Quote:
PS: When I use Wasapi using Intel HDMI audio (instead of Dirac WASAPI), the number of channels change properly (XMC-1 shows PCM 2.0 for stereo).
My video/hdmi card is AMD, not sure that makes any difference.

Once I got it set up, it is pretty reliable, except that when the chain "breaks," by changing HDMI source at the AVR, I have to go to the PC and reset it in the Dirac output selection slot. Dirac does not recover automatically when the AVR is switched back to the PC as the source, while thge other drivers (Win7, foobar) seem to do so. Not sure what that means. The science of coding a really resilient audio driver is no small thing, and the Dirac driver might not be quite as mature as some other audio drivers when it comes to fine points like that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
AudiocRaver is offline  
post #13 of 15 Old 03-09-17, 05:47 PM
HTS Moderator
 
Lumen's Avatar
Lou
 
Join Date: May 2014
Location: Indianapolis, IN
Posts: 2,207
My System
Re: HDMI Audio Setup Issues and Solutions

This thread was invaluable to me in getting my ASIO and Windows audio configuration working for full 8 channel HDMI support in REW!! I cannot say "thank you" enough!!

A few details of my system's issues are documented here. I would only like to add that AudiocRaver's suspicions about Nvidia cards were correct: some do work. Well, at least mine does. Now! I would also like to add that if you're still at a loss after trying the other tips, make sure that bit depths and sample rates match. Thanks again, Wayne.

.
I try to be as good as my dog thinks I am
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Lumen is online now  
 
post #14 of 15 Old 03-18-17, 08:14 PM Thread Starter
HTS Moderator
Reviewer
 
AudiocRaver's Avatar
Wayne Myers
 
Join Date: Jun 2012
Location: Lincoln, NE
Posts: 4,836
Re: HDMI Audio Setup Issues and Solutions

Glad it was helpful.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
AudiocRaver is offline  
post #15 of 15 Old 03-20-17, 08:50 AM
Senior Shackster
 
FargateOne's Avatar
 
Join Date: Mar 2015
Location: Québec, Canada
Posts: 341
My System
Re: HDMI Audio Setup Issues and Solutions

Quote:
Lumen wrote: View Post
This thread was invaluable to me in getting my ASIO and Windows audio configuration working for full 8 channel HDMI support in REW!! I cannot say "thank you" enough!!

A few details of my system's issues are documented here. I would only like to add that AudiocRaver's suspicions about Nvidia cards were correct: some do work. Well, at least mine does. Now! I would also like to add that if you're still at a loss after trying the other tips, make sure that bit depths and sample rates match. Thanks again, Wayne.
Totally agree!
FargateOne is offline  
Reply

Bookmarks

Tags
audio , hdmi , issues , setup , solutions

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome