sub sounds terrible - Page 2 - Home Theater Forum and Systems - HomeTheaterShack.com

Reply
 
Thread Tools
post #11 of 13 Old 02-03-12, 12:22 PM
Elite Shackster
 
Mike P.'s Avatar
Mike
 
Join Date: Apr 2007
Location: Chitek Lake, Sask.
Posts: 19,397
Re: sub sounds terrible

If you went with DIY, what would your budget be for the driver and an amp?

We're all in this together!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Mike P. is offline  
Sponsored Links
Advertisement
 
post #12 of 13 Old 02-16-12, 08:09 PM Thread Starter
Shackster
 
speaker-seeker's Avatar
Matt
 
Join Date: Jan 2011
Location: southern ontario canada
Posts: 21
Re: sub sounds terrible

i plan on upgrading the 8" drivers on my home made sub with the tc sounds epic 8. for the amp ill use the one i have now till it dies. I might get a car amp with a computer power supply to power it or ill get a crown xls 1000
speaker-seeker is offline  
post #13 of 13 Old 02-17-12, 06:47 PM
Senior Shackster
 
yoda13's Avatar
Yoda
 
Join Date: Feb 2012
Location: East of West, Canada
Posts: 349
My System
Re: sub sounds terrible

I had ordered a BASS12 last year. I wasn't expecting much of course. Took it out of the box, hooked it up, played it, scratched my head, unhooked it, packed it back in the box and return it the day after. It made my PSW10 sound like Seaton Submersive...well not quite, but you get my point.

I would really look into the PA-150 like suggested earlier. I have 2 of it's smaller sibling and they are a fantastic value. The fit and finish is of the class of a much more expensive category. I had 2 Bic F12 before and although they start rolling off quickly at around 30hz, they are quite more articulate and precise. Just a thought...
yoda13 is offline  
Reply

Bookmarks

Tags
12" , broken , problems , sounds , subwoofer , terrible , tuning

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome