Wsb55 - Too Many Issues to Handle - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 3 Old 12-19-10, 10:24 PM Thread Starter
New Member
 
Join Date: Dec 2010
Posts: 2
Wsb55 - Too Many Issues to Handle

Hello. I have had a Mits Wsb55 since 2004. It saw no use from 2005-2010, when in January I took it from storage and began to use it as our family tv. It worked fine until last week when it suddenly stopped powering up. After perusing the various threads, I've come to the conclusion that my front panel is not working (as in, no button responses nor LEDs). As per suggestion in another thread, I disconnected the front panel and tried to turn the tv on via the remote. Doing so produced a click, as if the tv were turning on, followed a few seconds later by another tick (perhaps saying it was turning off).

I put a multimeter on many test sites (according to the service manual), and all seemed to have power coming, and going to them. I was at a loss, and decided to take a step away from it for a bit. Upon returning, however, I found myself unable to to produce the clicking noise again no matter what.

Being that it is the holiday season, I am unable to drop a couple of hundred into having it serviced - nor am I willing if it is something I can do on my own. Any ideas?
dentarthurdent is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-19-10, 10:28 PM
Plain ole user
 
lcaillo's Avatar
Tech Guru
 
Join Date: May 2006
Location: Gainesville, FL, USA
Posts: 11,121
Send a message via AIM to lcaillo
Re: Wsb55 - Too Many Issues to Handle

You will have to troubleshoot the unit. If you don't get any response, some voltages must not be present. I would get the service manual and check again, then report what is correct and what is not.

Looking for me, just google my username. I have used the same one for most sites for many years.
lcaillo is offline  
post #3 of 3 Old 12-19-10, 11:40 PM Thread Starter
New Member
 
Join Date: Dec 2010
Posts: 2
Re: Wsb55 - Too Many Issues to Handle

Thanks, Leonard. I am going to pull the chassis out tomorrow and go to work. I noticed a faint smell of something burning when I got my face down close... which is a bummer.
dentarthurdent is offline  
Reply

Bookmarks

Tags
handle , issues , wsb55

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome