Sony KDF-E42A10 blinking red power/standby led - Home Theater Forum and Systems - HomeTheaterShack.com

 1Likes
  • 1 Post By putox1051
 
Thread Tools
post #1 of 8 Old 07-28-11, 11:21 AM Thread Starter
Shackster
Mike
 
Join Date: Nov 2009
Location: White Lake, MI
Posts: 22
Sony KDF-E42A10 blinking red power/standby led

Set turns on , power/standby led blinks green several times, changes to red and blinks 3 times in sequence forever, no picture or sound. Owners manual says "contact a Sony Service center". Anyone have a clue as to what might have failed. I'm the original owner, the set has been problem free for 5-6 years, worked great until yesterday morning.
putox1051 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-29-11, 10:28 AM
Elite Shackster
 
mechman's Avatar
Steve Mechelke -mech
 
Join Date: Feb 2007
Location: Empire Township, MN
Posts: 14,914
My System
Re: Sony KDF-E42A10 blinking red power/standby led

Is it three blinks then? Or is it blinking continuously? A continuous blink is the lamp I believe. Which may not be unheard of if you haven't replaced it yet.
mechman is offline  
post #3 of 8 Old 07-29-11, 10:36 AM
Elite Shackster
 
mechman's Avatar
Steve Mechelke -mech
 
Join Date: Feb 2007
Location: Empire Township, MN
Posts: 14,914
My System
mechman is offline  
post #4 of 8 Old 07-29-11, 02:12 PM Thread Starter
Shackster
Mike
 
Join Date: Nov 2009
Location: White Lake, MI
Posts: 22
Re: Sony KDF-E42A10 blinking red power/standby led

According to the service manual, a sequence of 3 blinks indicates a lamp door or lamp problem. So I popped open the lamp access port, opened & closed the lamp door, put everything back together, nothing changed. Next, I repeated the above, along with removing & reseating the lamp assembly itself. Re-assembled everything, & the problem was solved. Apparently, the lamp assembly had somehow come loose by itself. Or, the lamp door latch & associated micro-switch just needed to be cycled several times.
charbo6 likes this.
putox1051 is offline  
post #5 of 8 Old 07-29-11, 07:12 PM
Shackster
 
Join Date: Jul 2011
Location: Chesterfield, VA
Posts: 94
Re: Sony KDF-E42A10 blinking red power/standby led

That set and many Sony's have 2 switches in series. One on the lamp door, and one directly under the lamp. The one under the lamp usually causes the 3 code, the lamp only has to flex a few mm and it breaks the switch contacts.

If you have an ongoing problem with this, check that the switch under the lamp hasn't come loose, it has a small screw holding it in position.

Jim
74f100 is offline  
post #6 of 8 Old 11-16-11, 04:37 PM
New Member
 
Join Date: Nov 2011
Posts: 1
Re: Sony KDF-E42A10 blinking red power/standby led

I fixed my TV

my lamp blowup and I got a new one from amazon, It's an original one from Philips and came with casing.
I changed the lap very easy and did some cleaning, The TV turned on for a few minutes and then it shut off and the power light blinked 3 times and if i tried to turned on again it just turn the power led green and then it start to blink red three times. I tried removing the lamp several times and then put it on again and still had the 3 red blinks. I leave it all night unplugged and try the same (remove lamp, turn on TV) and at first it turn on but in a few minutes it shut off and start to blink red again.

So what I did is changed the lamp casing of the new lamp to the old casing, and that seems to solved the problem.

I noticed the old casing has some metal in the interior of the lamp area and the front crystal fits tighter. I believe that the new casing was overheating and the TV was protecting itself and tuned off.

also vacuum all the fan area and the inside of the light tunnel helps.
fash is offline  
post #7 of 8 Old 11-16-11, 04:45 PM
Shackster
 
Join Date: Jul 2011
Location: Chesterfield, VA
Posts: 94
Re: Sony KDF-E42A10 blinking red power/standby led

If the case of the new lamp doesn't contact the switch under the lamp, you get a 3 code. Those switches are also prone to failure.
74f100 is offline  
post #8 of 8 Old 06-25-16, 03:30 PM
Pending
 
Join Date: Jun 2016
Posts: 1
Thumbs up Re: Sony KDF-E42A10 blinking red power/standby led

Same solution worked for me! Thanks!
charbo6 is offline  
Reply

Bookmarks

Tags
blinking , kdfe42a10 , led , power or standby , red , sony

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome