Is my receiver broken? Center speaker not working at all.... - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 8 Old 10-06-09, 06:28 PM Thread Starter
New Member
redphinn
 
Join Date: Oct 2009
Location: Barrie
Posts: 4
Question Is my receiver broken? Center speaker not working at all....

Hi there, glad that I found this forum and I really hope someone here can shed some light on my situation. I recently picked up a used av receiver; I have spent the last few days gathering everything else I needed to make it work. I have successfully hooked up the front left and right and the surround right and left but I can't seem to get the center speaker to give me any sound. I've tried two different speakers on it and I've even tried to use the center pre-out to see if the tv would act as my center speaker.

Here's my setup:
Pioneer vsx-509s (oldie but a goodie)
aiwa subwoofer 150w self-powered
5 jvc speakers alternatively I have also tried using the speakers from my old all in one surround

in setting up the receiver I did notice that in the speaker selection menu you can turn off the center speaker....this stumped me at first because it was set to off to begin with; after changing that setting I still can't get any sound.

I'm beginning to think I bought a dud and maybe I should look for another receiver.....what do you guys think???

I'm open to any suggestions, I even looked to see if there was a way to reset my receiver but that doesn't seem to be an option.

Last edited by redphinn; 10-06-09 at 06:29 PM. Reason: spelling mistake
redphinn is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-06-09, 07:01 PM
Banned!
 
Join Date: Sep 2006
Posts: 3,807
Re: Is my receiver broken? Center speaker not working at all....

There should be auto test tones built into the reciever, a pink noise that outputs from each of the speakers individually. After turning the Center to "on", does the pink noise skip the center?
eugovector is offline  
post #3 of 8 Old 10-06-09, 07:03 PM Thread Starter
New Member
redphinn
 
Join Date: Oct 2009
Location: Barrie
Posts: 4
Re: Is my receiver broken? Center speaker not working at all....

When I had the speaker set up incorrectly with the center as off it would skip it entirely on the test tones. Once I changed it to show the center it does go through it on the test tone but there is no noise.
redphinn is offline  
post #4 of 8 Old 10-06-09, 07:27 PM
HTS Senior Moderator
 
Prof.'s Avatar
The Mad Professor
 
Join Date: Oct 2006
Location: Murraylands South Aust
Posts: 8,324
My System
Re: Is my receiver broken? Center speaker not working at all....

My guess is that it's a dud!!
If the centre channel was turned off when you bought it..I would say that the previous owner disconnected it because there was no output..possibly a blown output stage..

Prof..
Home Theatre...the never ending story!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Prof. is offline  
post #5 of 8 Old 10-06-09, 08:35 PM Thread Starter
New Member
redphinn
 
Join Date: Oct 2009
Location: Barrie
Posts: 4
Re: Is my receiver broken? Center speaker not working at all....

Your theory sounds like what I feared.....back to the Hock Shop I go....hopefully they don't give me too hard a time returning/exchanging for another one.
If they do give me my money back I saw another system on Kijiji that looks pretty good; it's newer too. You have anything good to say about Panasonic with quest speakers? The model is SA-HE75.
Thanks again for your advice.
redphinn is offline  
post #6 of 8 Old 10-06-09, 08:43 PM
HTS Senior Moderator
 
Prof.'s Avatar
The Mad Professor
 
Join Date: Oct 2006
Location: Murraylands South Aust
Posts: 8,324
My System
Re: Is my receiver broken? Center speaker not working at all....

Sorry, I'm not familiar with that model but someone else might be..

Prof..
Home Theatre...the never ending story!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Prof. is offline  
post #7 of 8 Old 10-09-09, 08:02 PM
Shackster
 
deafbykhorns's Avatar
deafbykhorns
 
Join Date: Oct 2009
Location: Florida
Posts: 8
Re: Is my receiver broken? Center speaker not working at all....

Are you using 5.1 program material? may not output for music
deafbykhorns is offline  
post #8 of 8 Old 10-09-09, 10:33 PM Thread Starter
New Member
redphinn
 
Join Date: Oct 2009
Location: Barrie
Posts: 4
Re: Is my receiver broken? Center speaker not working at all....

So the verdict is in....I took the receiver back to where I bought it and they tested the center output channel and there was absolutely no sound....I traded the receiver in for a Yamaha HTR5830 which is pretty cool and the sound works on this one so Yay!

Thanks to everyone for your help with my issue.....I will cruise on by here whenever I have any questions and maybe try and answer a few while I'm at it.
redphinn is offline  
Reply

Bookmarks

Tags
center speaker , pioneer vsx-509s

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome