Toshiba 42HP66 has sound, but no picture - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 10 Old 01-13-09, 06:24 AM Thread Starter
Shackster
 
Sprtex's Avatar
Tony
 
Join Date: Sep 2007
Location: Pearland, Texas
Posts: 53
Toshiba 42HP66 has sound, but no picture

Date on this Plasma TV is February 2006.

This set is in our Master Bedroom and is hardly used. It was on for about 5 minutes then I heard a pop...then so picture. I can still hear the sound, though.

I searched online a this doesn't seem to be that uncommon of a problem. But I can't find anyone with any difinitive solutions. Any ideas?

I suppose it's off to my neighborhood service center for a visit. Has anyone had this issue that might have a rough idea of what is going on and a ball park figure I could expect this visit to cost me?

Thanks for any input.

Tony
Sprtex is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 01-13-09, 02:09 PM
HTS Administrator
 
lcaillo's Avatar
Tech Guru
 
Join Date: May 2006
Location: Gainesville, FL, USA
Posts: 11,114
Send a message via AIM to lcaillo
Re: Toshiba 42HP66 has sound, but no picture

Sounds like it needs some troubleshooting. Are there any LEDs lit or flashing?

Looking for me, just google my username. I have used the same one for most sites for many years.
lcaillo is offline  
post #3 of 10 Old 01-13-09, 03:37 PM Thread Starter
Shackster
 
Sprtex's Avatar
Tony
 
Join Date: Sep 2007
Location: Pearland, Texas
Posts: 53
Re: Toshiba 42HP66 has sound, but no picture

Green LED on bottom right corner of panel is light when on. Red when off. Can change channels and hear different shows, just have a completely black screen.

Thanks for replying.
Sprtex is offline  
post #4 of 10 Old 01-13-09, 03:45 PM
HTS Administrator
 
lcaillo's Avatar
Tech Guru
 
Join Date: May 2006
Location: Gainesville, FL, USA
Posts: 11,114
Send a message via AIM to lcaillo
Re: Toshiba 42HP66 has sound, but no picture

I could only guess...find a servicer who has experience with Toshiba PDPs.

Looking for me, just google my username. I have used the same one for most sites for many years.
lcaillo is offline  
post #5 of 10 Old 01-13-09, 04:11 PM Thread Starter
Shackster
 
Sprtex's Avatar
Tony
 
Join Date: Sep 2007
Location: Pearland, Texas
Posts: 53
Re: Toshiba 42HP66 has sound, but no picture

Will do, thx.
Sprtex is offline  
post #6 of 10 Old 07-01-09, 03:08 PM
Charlie
 
Join Date: Jul 2009
Posts: 1
Re: Toshiba 42HP66 has sound, but no picture

Did you ever get this TV serviced to see what the problem was, I am having the same problem with mine.
Charliew88 is offline  
post #7 of 10 Old 07-04-09, 11:26 AM Thread Starter
Shackster
 
Sprtex's Avatar
Tony
 
Join Date: Sep 2007
Location: Pearland, Texas
Posts: 53
Re: Toshiba 42HP66 has sound, but no picture

I found an authorized service center and still have not made it over to them.

I actually forgot about it...too many honey do's on the list. The model I have was one of the first plasma Toshiba built and has a history of this issue. But I can't give you an exact answer until I have it looked at.

I'm glad you reminded me. I'll try to get it over to them this week.
Sprtex is offline  
post #8 of 10 Old 01-13-10, 07:57 PM
New Member
Labrat
 
Join Date: Jan 2010
Location: Norton, Ohio
Posts: 1
Re: Toshiba 42HP66 has sound, but no picture

I have the same model. Purchased in April 2006. Tonight I heard a loud "zap", almost like a huge static crack, and the picture went dead. Prior to this I didn't notice any warning sign except that I have been noticing green snow for quite a while but after watching for a while, my eyes must adjust to it. After cooling down for 2 hours, still no picture. I probably will not try to get this repaired, but will hang onto it in case I find someone to look at it. I think that the prices and quality are much improved from '06 and will probably replace it with a 42" LCD.
I still would love to know what is wrong with this set and wil ltry to call Toshiba tomorrow. I will post anything I find out.
labrat_gb is offline  
post #9 of 10 Old 01-13-10, 10:26 PM
HTS Administrator
 
lcaillo's Avatar
Tech Guru
 
Join Date: May 2006
Location: Gainesville, FL, USA
Posts: 11,114
Send a message via AIM to lcaillo
Re: Toshiba 42HP66 has sound, but no picture

The most common problem that occurs with a large "crack", "snap", or "pop" sound is a failure in the YSUS or YDrive areas. That is just a wild guess, however, and the set will require examination to detemine the nature of the problem.

Looking for me, just google my username. I have used the same one for most sites for many years.
lcaillo is offline  
post #10 of 10 Old 05-20-10, 09:45 PM
New Member
Randy
 
Join Date: Feb 2010
Posts: 3
Re: Toshiba 42HP66 has sound, but no picture

Regarding the 42HP66 with no picture...

That sound you heard was the infamous 'pop of death" This model TV was prone to do that. I have one that I was given and this was also the issue. The Ysus board had a large driver chip fail. When these sets were made there was an adhesive spacer pad on the back of the Ysus and Zsus boards. The glue on these pads conducted enough electrical current through them that the driver chip failed. The ysus boards are commonly available rebuilt on ebay for around $100. I would highly recommend having a technician replace it or at least someone familiar with working around High Voltage. (these things will shock the living snot out of you if you're not careful ) The service manual is available for this on ebay as well. My set lost the Ysus and the XRlt interface board. The Ysus replacement restored the picture but the right side was distorted, replacing the Xrlt board (another $20 on Ebay) restored the full picture. Now all I need is a stand, the people who had this set mounted it on a wall and had tossed the stand. So if anyone has one of these sets that they're not planning to repair, I would LOVE to buy a stand from them.
Randyincv is offline  
Reply

Bookmarks

Tags
42hp66 , picture , sound , toshiba

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome