OPPO BDP-83 Blu-ray Player Firmware Updates - Page 3 - Home Theater Forum and Systems - HomeTheaterShack.com

Reply
 
Thread Tools
post #21 of 25 Old 02-08-11, 07:50 AM
Shackster
 
akeoo7's Avatar
AKE
 
Join Date: Feb 2010
Location: Lebanon
Posts: 64
Re: OPPO BDP-83 Blu-ray Player Firmware Updates

Hi Everybody
New Firmware available for BDP83 on oppo's site now. It is the BDP-83-54-0130B.
Thought I might spread the word.
Have a nice day
akeoo7 is offline  
Sponsored Links
Advertisement
 
post #22 of 25 Old 02-08-11, 10:42 AM
Banned!
 
Join Date: May 2009
Location: London UK
Posts: 4,015
Re: OPPO BDP-83 Blu-ray Player Firmware Updates

Quote:
akeoo7 wrote: View Post
Hi Everybody
New Firmware available for BDP83 on oppo's site now. It is the BDP-83-54-0130B.
Thought I might spread the word.
Have a nice day
Thanks for the heads up AKE

Firmware Release:

Public Beta Test Release
Release date: February 1, 2011.
Category: Public Beta Test Version

Main Version: BDP83-54-0130B
Loader Version: BE2731 or BT0431
Sub Version: MCU83-27-0326
Installation Instructions and Download Link: Click Here
recruit is offline  
post #23 of 25 Old 02-12-11, 02:20 PM
Senior Shackster
patchesj
 
Join Date: Jun 2009
Posts: 372
Re: OPPO BDP-83 Blu-ray Player Firmware Updates

Anyone notice LPCM drop outs during 7.1 TrueHD playback? My PR-SC885P seems to be dropping and "clicking" on the left channel, but all goes away when I change to bitstream output. Didn't have this issue before the latest firmware release.

On a side note, I've found that bitstream is sounding WAY better now than LPCM (aside from the left channel issue).
patchesj is offline  
 
post #24 of 25 Old 03-27-12, 10:28 AM
Shackster
 
Join Date: Oct 2011
Posts: 13
Re: OPPO BDP-83 Blu-ray Player Firmware Updates

Thanks for the headsup on the new firmware. This loving the OPPO BDP83 SE.
yammyguy is offline  
post #25 of 25 Old 03-31-12, 12:35 PM
Shackster
 
Join Date: Jan 2012
Location: Manvel, Texas
Posts: 8
My System
Re: OPPO BDP-83 Blu-ray Player Firmware Updates

BDP-83
My current firmware is BDP83-58-1215. Is that the most current or the beta in prior post?

I'm having an issue with player; whenever i load a movie I don't get any audio on previews. I do however get audio when the feature starts.

Using Pioneer SC-57 and JVC HD-350 on a 120" screen.

thanks,
rencan is offline  
Reply

Bookmarks

Tags
bdp-83 , blu-ray , firmware , oppo , player , updates

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome