Internet speed problems - Page 4 - Home Theater Forum and Systems - HomeTheaterShack.com

 13Likes
Reply
 
Thread Tools
post #31 of 38 Old 12-17-16, 10:57 AM Thread Starter
 
ellisr63's Avatar
Ron
 
Join Date: Feb 2012
Location: In the Home Theater
Posts: 5,769
My System
Re: Internet speed problems

I am upgrading my Netgear switches to Cisco Business class switches. I have been running a Cisco SG200-26 in our HT for several years now, and since I am running out of ports, I decided to move up to 18-20 port switches. I picked up a SG200-18 for our LR, and a SG300 to run next to our Netgear R7000 router (all 3 pieces were less than the first SG200 was). The guy that I bought the SG300 from gave me a 890 series router (labeled 891)...not sure if it will be easily configured or not, but if i keep it I hope it is better than the R7000 is.
http://www.cisco.com/c/en/us/product...78-519930.html

My Home Living room Theater
Samsung 65" FP, Yamaha CX-A5100, Xilica XP4080, (5) JBL 8340As, PS3, XBox One, (1) Asus mini pc, (2) Furman Power Conditioners, Darbee Darcet, Oppo UDP-203, and a Project RPM 1.5 Carbon turntable..
ellisr63 is offline  
Sponsored Links
Advertisement
 
post #32 of 38 Old 12-19-16, 06:44 PM Thread Starter
 
ellisr63's Avatar
Ron
 
Join Date: Feb 2012
Location: In the Home Theater
Posts: 5,769
My System
Re: Internet speed problems

Today i spent several hours updating the firmware of my SG200-26 switch. I learned that Cisco requires you to do every update in order to do the next update, and that they changed the boot files on a few of them too, which meant I had to learn how to update that with TFTPD64 for the boot files. This last part took me the longest to figure out exactly what had to be done to do this every time. Once I had that figured out it went pretty smoothly, and fast...other than having to reboot after each firmware update, and boot update. I don't know what they did in the updates, but after doing a couple of them the Switch seemed to boot faster than it had been previously.

My Home Living room Theater
Samsung 65" FP, Yamaha CX-A5100, Xilica XP4080, (5) JBL 8340As, PS3, XBox One, (1) Asus mini pc, (2) Furman Power Conditioners, Darbee Darcet, Oppo UDP-203, and a Project RPM 1.5 Carbon turntable..
ellisr63 is offline  
post #33 of 38 Old 12-19-16, 07:03 PM
HTS Moderator
Reviewer
 
theJman's Avatar
Jim
 
Join Date: Mar 2012
Location: New Joisey
Posts: 3,242
My System
Re: Internet speed problems

Maybe it got tired of all the reboots and simply decided to expedite the process. Glad it worked out in the end - I know it was quite the journey.
ellisr63 likes this.

-Jim

If you take yourself too seriously, expect me to do the exact opposite
theJman is offline  
 
post #34 of 38 Old 12-19-16, 07:09 PM Thread Starter
 
ellisr63's Avatar
Ron
 
Join Date: Feb 2012
Location: In the Home Theater
Posts: 5,769
My System
Re: Internet speed problems

Quote:
theJman wrote: View Post
Maybe it got tired of all the reboots and simply decided to expedite the process. Glad it worked out in the end - I know it was quite the journey.
I have 2 more switches arriving tonight... I will be trying to get the firmware up to date tomorrow on those, and then get them into the system too. I was reading that I should arrange all my IP addresses to be in order, limit the IP addresses to the number of devices (so if i have 10 devices I would have only 10 IP addresses available...instead of hundreds), and use their MAC addresses too. Yesterday i found out that when you do a Guest account you can do it as a Virtual port, and restrict the usage to only the internet so no one has access to your Network. That is a nice feature IMO. It is going to take me a while to get all the IP addresses reassigned as static and in small groups. I wonder if by doing it this way if it will speed up my LAN...

My Home Living room Theater
Samsung 65" FP, Yamaha CX-A5100, Xilica XP4080, (5) JBL 8340As, PS3, XBox One, (1) Asus mini pc, (2) Furman Power Conditioners, Darbee Darcet, Oppo UDP-203, and a Project RPM 1.5 Carbon turntable..
ellisr63 is offline  
post #35 of 38 Old 12-19-16, 07:35 PM
HTS Moderator
Reviewer
 
theJman's Avatar
Jim
 
Join Date: Mar 2012
Location: New Joisey
Posts: 3,242
My System
Re: Internet speed problems

I seriously doubt it will be any faster. Once a route is established it will be kept in the ARP cache, and from then on communications between devices will be port-to-port directly (at least until you reboot the switch or manually clear the cache). If you had a /20 or larger address space and ran it as one flat network - without subnets - there might be some benefit to keeping things sequential, but with the speed of most switches today I doubt you would notice a benefit in your situation.
ellisr63 likes this.

-Jim

If you take yourself too seriously, expect me to do the exact opposite
theJman is offline  
post #36 of 38 Old 12-19-16, 08:30 PM Thread Starter
 
ellisr63's Avatar
Ron
 
Join Date: Feb 2012
Location: In the Home Theater
Posts: 5,769
My System
Re: Internet speed problems

Quote:
theJman wrote: View Post
I seriously doubt it will be any faster. Once a route is established it will be kept in the ARP cache, and from then on communications between devices will be port-to-port directly (at least until you reboot the switch or manually clear the cache). If you had a /20 or larger address space and ran it as one flat network - without subnets - there might be some benefit to keeping things sequential, but with the speed of most switches today I doubt you would notice a benefit in your situation.
We have close to 40 devices spread over 3 switches with switches being 18, 20, and 26 ports running to our Netgear R7000 router with DD-WRT firmware.

My Home Living room Theater
Samsung 65" FP, Yamaha CX-A5100, Xilica XP4080, (5) JBL 8340As, PS3, XBox One, (1) Asus mini pc, (2) Furman Power Conditioners, Darbee Darcet, Oppo UDP-203, and a Project RPM 1.5 Carbon turntable..
ellisr63 is offline  
post #37 of 38 Old 12-20-16, 01:47 PM Thread Starter
 
ellisr63's Avatar
Ron
 
Join Date: Feb 2012
Location: In the Home Theater
Posts: 5,769
My System
Re: Internet speed problems

Today is going much better... I almost have all the firmware completed on the SG200-18, and next will be the SG300-20. I still have to decide if i am going to keep the Cisco 890 Router or sell it, and keep using the R7000 WIFI Router.

My Home Living room Theater
Samsung 65" FP, Yamaha CX-A5100, Xilica XP4080, (5) JBL 8340As, PS3, XBox One, (1) Asus mini pc, (2) Furman Power Conditioners, Darbee Darcet, Oppo UDP-203, and a Project RPM 1.5 Carbon turntable..
ellisr63 is offline  
post #38 of 38 Old 05-05-19, 03:54 PM
Shackster
 
deathshad0w's Avatar
 
Join Date: May 2019
Posts: 6
Re: Internet speed problems

I've found a list of good programs that may help you out with the speed problems, check it out.
deathshad0w is offline  
Reply

Bookmarks

Tags
internet , problems , speed

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome