Mach 5 IXL 2.2 seems off - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 10 Old 02-06-10, 02:14 PM Thread Starter
Senior Shackster
Adam
 
Join Date: Nov 2009
Posts: 393
Mach 5 IXL 2.2 seems off

Hey! i see you've got experience with the Mach5 brand, I've got a 18 inch ixl 2.2 that just seems way off. The driver has much lower sensitivity than advertised and the T/S were all way off. I'll have to get the measurements again, but i ended up putting it on the back burner. Its been over a year now with no use on it, and the best i've been offered was a recone... it seems more like a motor issue to me and i highly doubt a recone would fix the sensitivity issue.

any ideas?
Binary is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 02-06-10, 04:27 PM
Elite Shackster
 
Mike P.'s Avatar
Mike
 
Join Date: Apr 2007
Location: Chitek Lake, Sask.
Posts: 19,397
Re: Calling out Mike P.

I'm not sure what the issue would be. I have a pair of IXL-18's, a IXL-15 and a IXL-12, all of them perform as expected. I would be curious to see what your measurements are.




We're all in this together!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Mike P. is offline  
post #3 of 10 Old 02-08-10, 02:58 PM Thread Starter
Senior Shackster
Adam
 
Join Date: Nov 2009
Posts: 393
Re: Calling out Mike P.

well, i had it tested by mwmkravchenko on here, and he said the spl was specing to something like 79db 1w/m which is quite a bit off of the 89db 2.83v. the MMS was way off and the FS was higher than expected. It seemed so much like a motor problem that when mark from mach5 offered me a recone i didnt even bother, woulda cost me 50 bucks just to ship it out. it really does bug me though, i paid good money for the driver and its factory . btw, on a side note, im the guy who designed to mach 5 audio logo. lol. Im gonna have to borrow marks wt3 so i can run it again, but it was totally off. so much so he suggested i buy a new driver. i did. sdx 15.
Binary is offline  
 
post #4 of 10 Old 02-08-10, 03:52 PM
Elite Shackster
 
Mike P.'s Avatar
Mike
 
Join Date: Apr 2007
Location: Chitek Lake, Sask.
Posts: 19,397
Re: Calling out Mike P.

Mine are the original IXL-18.4 single coil, I've had no issues with output from them. They are spot on. If the SPL is out 10 db either there is something seriously wrong with the sub or the testing is faulty. If it were me I'd retest the sub, if possible.




We're all in this together!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Mike P. is offline  
post #5 of 10 Old 02-08-10, 04:08 PM Thread Starter
Senior Shackster
Adam
 
Join Date: Nov 2009
Posts: 393
Re: Calling out Mike P.

Well, i am going to have to test it again, once i do i will post my results here so you can see what is going on. It would be a a beast of a sub for a car if i could get it to spec right but if its only 79db theres no way im gonna use it.
Binary is offline  
post #6 of 10 Old 02-08-10, 04:40 PM
Elite Shackster
 
Ricci's Avatar
Josh
 
Join Date: May 2007
Location: Louisville, KY
Posts: 2,431
Re: Calling out Mike P.

I'd have to think that either the driver has something drastically wrong with it (like a motor that is partially demagnetized causing a huge loss in strength) or the tests were faulty.
Ricci is offline  
post #7 of 10 Old 02-09-10, 03:49 AM
Senior Shackster
David Burn
 
Join Date: May 2007
Location: Albury, Australia
Posts: 262
Re: Calling out Mike P.

Mine works perfect, have you actually tried it in a box or just tested the T/S? Not trying to be rude but I would be interested to know if you give it a try in an enclosure to see how it performs.
davidburn is offline  
post #8 of 10 Old 02-10-10, 04:46 PM
bjs
Senior Shackster
bjs
 
Join Date: Jun 2008
Location: Vancouver, BC
Posts: 162
Re: Calling out Mike P.

Quote:
Binary wrote: View Post
well, i had it tested by mwmkravchenko on here, and he said the spl was specing to something like 79db 1w/m which is quite a bit off of the 89db 2.83v. the MMS was way off and the FS was higher than expected. It seemed so much like a motor problem....
You say the "MMS was way off" and "FS was higher"...so why do you then conclude it is the motor? These aren't dependant on the motor.

If you are thinking motor because the sensitivity is low, then I'd point out that sensitivity is a calculation and it is strongly dependant on MMS and Fs. Measure those wrong and your sensitivity will be wrong.

Therefore, given your MMS is "way off" (an easily controlled parameter in loudspeaker design and hard to make "way off") and your FS too, I bet the driver is fine and it is all measurement error.
bjs is offline  
post #9 of 10 Old 02-10-10, 05:24 PM Thread Starter
Senior Shackster
Adam
 
Join Date: Nov 2009
Posts: 393
Re: Calling out Mike P.

i havent tested it in a box, i have tried a small amount of free air. i'm dead set positive that i'm going to need to measure it again. im hoping its perfect, i love the look/specs of this driver! it just has to work as its supposed to. lol.
Binary is offline  
post #10 of 10 Old 05-28-10, 09:55 PM
Shackster
Maq
 
Join Date: Mar 2008
Location: Canada
Posts: 13
Re: Mach 5 IXL 2.2 seems off

Bump. Any development with this?
marstedt is offline  
Reply

Bookmarks

Tags
calling , mike

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome