Hitachi P60X901(60" not 50") led flashes 2 times (not 3) - Home Theater Forum and Systems - HomeTheaterShack.com

 3Likes
Reply
 
Thread Tools
post #1 of 95 Old 09-18-11, 08:33 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

Hello everyone.

I found this forum after my plasma would't come back on after dinner a few nights ago.
The blue led light blinks twice which i have found (thanks to this forum) means there is something wrong with the XSUS board.

I have combed through this (and other forums) looking for some insight about this error but most problems with these Hitachi Plasmas seem to circle around the buffers on the SDRs and the caps on the power supply.
Jason76's thread "Hitachi P50H401 led flashes 3 times" discribes the problem and solution so effectively that i almost which my led was blinking 3 times.

I have read that in order to test the xsus board i can simply unhook it from the Ysus board and if the tv screen powers up i know the xsus board is the problem. [Please correct me if i am wrong about that]

My question is: if the xsus board is the problem (or one of the problems) can it be repaired like the power supply or SDRs? I have not read where anyone sent this board out for repair. I have only read where people bought a replacement board.

Thanks for your help and i will keep this thread updated until the very end.

A little history on the tv...
Bought it refurbished from EUCweb over 3 years ago. Opted not to get the extended warranty and glad i did... the tv died a few weeks after the 3 year mark. And i believe 3 year was the maximum serive length they would give you. IIRC, that 3 year coverage was over $500! I would have been REALLY mad.

TV has been wall mounted and untouched for the most part.
Installed in wall power comditioner at the time of purchase just in case. No loud pops, problems or signs of trouble since day of purchase.

Well about a year ago the tv wouldnt come on and and the led was flashing. I dont remember if it was the blue led or red but i unplugged it for about an hour and everything has worked fine since.

I also updated the firmware as of a year ago courtesy of Hitachi customer service.

Last edited by KYBOSH; 09-19-11 at 08:57 AM.
KYBOSH is offline  
Sponsored Links
Advertisement
 
post #2 of 95 Old 09-18-11, 09:39 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

By the way, here are 2 pages from the repair manual showing some of the information I mentioned before.
Your thoughts and insights are greatly appreciated.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-pdp-panel-self-diagnosis-function.jpg  

Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-p60x901-panel-board-layout-diagram.jpeg  


Last edited by KYBOSH; 09-19-11 at 04:41 PM.
KYBOSH is offline  
post #3 of 95 Old 09-19-11, 01:02 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

Last night I got the TV down off the wall and began taking the back panel off.
As someone stated before there were a lot of screws.
Luckily I have the repair manual which gave me confidence that i would not be left with a handful of screws after the deed was done.

Taking the back panel off was straight forward enough.
In all there were only 3 different types of bolts/screws but they were many (50-60 or so).

Here's what she looks like with the back on & off.
You can see where everything is from the layout diagram in the previous post.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-backside.jpg  

Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-back-panel-off.jpg  


Last edited by KYBOSH; 09-19-11 at 04:50 PM.
KYBOSH is offline  
 
post #4 of 95 Old 09-19-11, 04:53 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

First thing I noticed (even before I pulled the back off) were the huge fans planted on both sides.
Some members on another forum installed fans on the back of their 50 inches to keep things cool as they say these TV generate a lot of heat. I actually had planned on doing this myself but was happy to see the engineers cut on corners on the P60. Needless to say the back was pretty dusty.

So with the back off I stepped away and took in the whole thing.
What struck me was the enormity of the the boards I was dealing with.
These boards are HUGE. Think small and medium sized pizza box huge!

After a few seconds I went straight to the XSUS board to see what I could see.
Being a circuit board novice, the only thing I knew to look for were scorched and puffy components and maybe even a leak but everything looked fine. I don't think there is anyway to eyeball a nonviolent short so I kept it brief. What I did do is take lots of high resolution photos (1944  2592) so i could come back to my desktop and scan over them in hopes of catching something I might have missed on the scene…

Here's what the XSUS board looks like from afar.
Sorry about that bar being in the way but I didn't want to take them off just yet.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-xsus.jpg  


Last edited by KYBOSH; 09-19-11 at 09:40 PM.
KYBOSH is offline  
post #5 of 95 Old 09-19-11, 04:58 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

And here are closeups of the caps on the XSUS look like.
The high res photo allows me to zoom in much better than this but again to me everything looked to be okay.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-xsus-closeup-caps-3rdq-.jpg  

KYBOSH is offline  
post #6 of 95 Old 09-19-11, 07:11 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

Before I moved on to the power supply I wanted to test the XSUS board.

As I mentioned in my first post that I read where some were able to test the XSUS board by disconnecting it from the other boards and looking to see if the TV powered up. If it powered up then the fault lied in the XSUS board. I wasn't sure this applied to my model but I figured it couldn't hurt anything to try.

So I disconnected the 2 cords (1 from the YSUS and 1 from the PSU) and the ribbon cable from the logic board and fired it back up.

This time instead of 2 blue LED flashing; I got 4.

According to the PDP self diagnosis sheet from the second post this indicates an error with the X-SUS, Y-SUS, SDR and/or PSU. Apparently the P60 didn't like what I just did. Thinking about it now I should have just disconnected the cord from the YSUS instead of all 3.

I reconnected the 3 cables/ribbons and powered to TV and got the 2 flashing blue LED again.

Now On To The Power Supply.

Last edited by KYBOSH; 09-19-11 at 09:42 PM.
KYBOSH is offline  
post #7 of 95 Old 09-19-11, 07:14 PM
Shackster
 
Join Date: Jul 2011
Location: Chesterfield, VA
Posts: 94
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

Top 3 transistors on the last picture? Can't tell from the picture, but those look to have blown. If not, check the whole row of transistors for shorted components.

Jim


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
74f100 is offline  
post #8 of 95 Old 09-19-11, 07:25 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

Quote:
74f100 wrote: View Post
Top 3 transistors on the last picture? Can't tell from the picture, but those look to have blown. If not, check the whole row of transistors for shorted components.

Jim
Thanks Jim!
I noticed that too but upon further inspected (I went back to the board) I figured it was a lighting issue.
Here's another pic of the same spot but at a different angle. It looks better but I will still test this out for a short.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-xsus-3rdq-topview.jpg  

KYBOSH is offline  
post #9 of 95 Old 09-19-11, 07:33 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

POWER SUPPLY UNIT

The first thing i noticed about the power supply was how much different it looked from the more common P50 PSUs. Not only is the layout different (and the board seems much bigger) but the PSU seems to be split into two connected only by a few wires.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-psu_2-copy.jpg  

Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-psu-2-board-divide-looking-up-.jpg  


Last edited by KYBOSH; 09-19-11 at 07:52 PM.
KYBOSH is offline  
post #10 of 95 Old 09-19-11, 07:45 PM Thread Starter
Senior Shackster
 
Join Date: Sep 2011
Posts: 104
Re: Hitachi P60X901(60" not 50") led flashes 2 times (not 3)

While the layout is different from the P50s PSU I was able to find a suspect CAP.
All the largest caps present on this PSU are either 450v-330F (35 mm dia), a 220v-1600F (35 mm dia) or 100v-3300F CAP (30mm dia). There is only one 100v-3300F CAPy and it was the one that's was bulging out a bit.

If you are looking at the pic of the main board I posted above its the one that's circled in yellow.
Here's a closeup at a different angle. Its not flagrant but its definitely puffed out.

All the other CAPS look fine.
Attached Thumbnails
Hitachi P60X901(60" not 50") led flashes 2 times (not 3)-psu-buffy-100v-3300uf-cap_2.jpg  


Last edited by KYBOSH; 09-20-11 at 11:43 AM.
KYBOSH is offline  
Reply

Bookmarks

Tags
flashes , hitachi , led , p60 not 50 , p60x901 , times , xsus

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome