mitsubishi WS-65315 error code 2-2 v24 - Page 2 - Home Theater Forum and Systems - HomeTheaterShack.com

Reply
 
Thread Tools
post #11 of 14 Old 07-03-14, 03:49 PM
Shackster
Scott
 
Join Date: Jul 2014
Location: Tucson, AZ
Posts: 14
Maybe ... Bad voltage regulator

Pulled the chassis out (again) and starting checking. No fuses were blown this time, mabe because I only cycled the power on the set once.

Looking downstream of the previously blown fuse there's a voltage regulator circuit. First observation was the resistance was only 1.9 ohms (uh-oh, that means over 12 amps at 24v - no wonder the fuse has been blowing) even after letting all the caps charge up. First suspect was an electrolytic cap which checked out good when I pulled it out. Resistance was still 1.9 ohms so I pulled the regulator IC and voila, circuit resistance was on the order of 25k ohms and the resistance between Vin and ground on the chip was only 2.1 ohms. I believe this chip is my culprit!

Got one on order as our local supply doesn't stock one. It's a holiday weekend so hopefully by middle of next week we'll be back in business. Will keep y'all posted.

Last edited by beg3yrs; 07-04-14 at 03:01 PM.
beg3yrs is offline  
Sponsored Links
Advertisement
 
post #12 of 14 Old 07-09-14, 08:16 PM
Shackster
Scott
 
Join Date: Jul 2014
Location: Tucson, AZ
Posts: 14
Solved!

Yes, it was the voltage regulator. Before I soldered in the new chip I was curious and measured the resistive load on the chip's output. About 2.5 ohms. Pretty low I thought. Did some more testing and found no caps downstream to be bad. Looked up the spec on this regulator. With an infinite heat-sink it handles up to 30W and can source 3A. So, I suppose even with that load, it's working well within spec.

Went ahead and soldered it in, replaced all the connectors and gave it the power on test.

Bummer, turned on and then turned off again. Different code though, 26. Hmm... there's no 26 in the manual. Let's unplug it and just try it again. Plugged it back in, powered on and it powered off again, this time with a code of 24 which is not in the manual either. One more try and voila, everything is working just fine. HURRAY! Just in time for the grandkid's three week visit which starts TOMORROW.

I'm wondering if power has to be cycled a few times before they system figures out it is OK. Regardless, we're done!
beg3yrs is offline  
post #13 of 14 Old 07-10-14, 06:35 PM
Plain ole user
 
lcaillo's Avatar
Tech Guru
 
Join Date: May 2006
Location: Gainesville, FL, USA
Posts: 11,121
Send a message via AIM to lcaillo
Re: mitsubishi WS-65315 error code 2-2 v24

Congratulations! Good job troubleshooting!




Looking for me, just google my username. I have used the same one for most sites for many years.
lcaillo is offline  
 
post #14 of 14 Old 07-10-14, 11:05 PM
Shackster
Scott
 
Join Date: Jul 2014
Location: Tucson, AZ
Posts: 14
Re: mitsubishi WS-65315 error code 2-2 v24

Quote:
lcaillo wrote: View Post
Congratulations! Good job troubleshooting!
Thanks. You professionals don't get paid enough!
beg3yrs is offline  
Reply

Bookmarks

Tags
22 , code , error , mitsubishi , v24 , ws

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome