Home Theater Forum and Systems - HomeTheaterShack.com - Reply to Topic

Thread: PT47WX53G convergence repair troubleshooting Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-25-12 07:40 PM
edennihy
Re: PT47WX53G convergence repair troubleshooting

I tried to make some adjustments but to no avail. The t.v. doesn't even respond to changing the input. What do you mean by scanning? The set does have channel scanning but that's not really accessible without the menu even appearing.
04-25-12 07:18 PM
lcaillo
Re: PT47WX53G convergence repair troubleshooting

Do you have scanning? Did you adjust the screen controls? Some sets are touchy about those controls.



04-25-12 03:18 PM
edennihy
Re: PT47WX53G convergence repair troubleshooting

Got a chance to open it again today. I replaced the possibly burned out resistor and took a while to really examine the soldering on the board. There did not seem to be any damaged joints but when I put it all back together and powered up the set the same problem occurred. To be a little specific from the back of the set when it is powered on the three bulbs are clearly glowing at the bottom but no light is coming out of the lamps above them. Any thoughts? Or perhaps any other information I could provide?
04-16-12 09:36 PM
edennihy
Re: PT47WX53G convergence repair troubleshooting

That's definitely an option. I did all of the work without completely removing the board so something may have been dinged around. Hopefully I will get some time to sit down and check it all out tomorrow.
04-16-12 06:50 PM
lcaillo
Re: PT47WX53G convergence repair troubleshooting

I am not sure that an open resistor would cause no video. IIRC it would usually cause shut down and would likely damage an IC. Something else must have changed. You can pull the ICs and the set should run fine with no convergence correction. You will have no convergence, but you should get an image.

Maybe you cracked a solder joint moving the boards around. Not an uncommon issue. Did you adjust anything?



04-16-12 03:20 PM
edennihy
Re: PT47WX53G convergence repair troubleshooting

Hey lcaillo,

All wires are accounted for. Upon closer inspection though R7011 one of the resistors directly in front of the convergence chips and often identified a a possible failure in these repairs is definitely discolored. Would it make sense for the system to fully power up and not return an error message though if this resistor was in fact burnt out?
04-15-12 07:34 PM
lcaillo
Re: PT47WX53G convergence repair troubleshooting

Even experienced techs miss one every now and then.



04-15-12 06:57 PM
edennihy
Re: PT47WX53G convergence repair troubleshooting

Thanks for the quick response lcaillo. This is my first repair of this magnitude so I know that's definitely an option. I've decided to wait until tomorrow to open it again to get a fresh perspective and I'll update the post then.
04-15-12 06:36 PM
lcaillo
Re: PT47WX53G convergence repair troubleshooting

You most likely missed a connection somewhere.



04-15-12 05:33 PM
edennihy
PT47WX53G convergence repair troubleshooting

Hey guys,

So a few weeks ago my set turned off and returned the 3 blinking red light error code. After some research we decided to go inside and perform the convergence repair as is apparently standard with these older sets. We replaced the two IC STK392-110 chips with two new STK392-120 chips, and also the R7060 and R701 resistors as those were the only two that appeared damaged. The two aforementioned resistors are 0.27ohm 1 watt resistors but we were only able to find 0.27ohm 5watt resistors to replace them with (possible source of problem?). All 6 of the commonly replaced 2.2 ohm resistors that are in front of the convergence chips appear to be intact. Anyways after putting everything back into place our set powers up fine and stays on with no error codes. However, we have absolutely no picture. The bulbs simply do not seem to be fully powering up. Anybody else have a similar problem or any suggestions?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!

 


For the best viewing experience please update your browser to Google Chrome