Home Theater Forum and Systems - HomeTheaterShack.com - Reply to Topic
Thread: Need help with my Denon AVR-1912!!! Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-16-14 07:04 AM
raja.ind91
Re: Need help with my Denon AVR-1912!!!

Hello Everyone,
I am new to this forum. I would like to share with you a similar problem that has come up in my Denon 1912 since yesterday. ( blue transparent squares and rectangles on the screen). I have tried below steps:
- changed my TV
-changed HDMI cable
-Reset the microprocessor ( few times)
-disconnect all inputs and speaker connections.
The problem continues even after trying out all the above. One more observation is that the Menus and setup wizard screens are also not appearing.
I would like to know how was the problem resolved in the previous cases posted here. I Would very much appreciate your vaulable inputs.
01-29-13 07:22 PM
Jungle Jack
Re: Need help with my Denon AVR-1912!!!

Quote:
tonyvdb wrote: View Post
Wow Jack, going off the beaten path are we LOL It will be interesting to hear your thoughts on the Denon.
It is Sonnie's fault. After reading about him use a 4520 to drive a pair of Martin Logan Prodigies and being so pleased that he even listed his Emotiva XPA-1 Monoblocks, as a fellow ML owner I was intrigued.

While I am not yet brave enough to attempt the same. Or lazy as my amplifiers are all hooked up to the Speaker Cables leaving only RCA runs to the AVR. I must say it is kinda fun learning a new AVR as I have not owned a Denon since the AVR-4800.
01-29-13 05:27 PM
tonyvdb
Re: Need help with my Denon AVR-1912!!!

Wow Jack, going off the beaten path are we LOL It will be interesting to hear your thoughts on the Denon.
01-29-13 05:19 PM
Jungle Jack
Re: Need help with my Denon AVR-1912!!!

Hello,
Well to put my money where my mouth is (so to speak), I picked up a Denon AVR-4520CI from the retailer that shall not be named for the purposes of this thread. While only a few hours in, the unit is utterly brilliant and appears to be brand new down to having the features sticker on the faceplate. My 3008 is an A-Stock and has been perfect.

While I was honestly tortured between the 4520 and the Onkyo 5009/5010, the Preamp Only Mode, AirPlay, and also wanting to mix it up after owning 4 Onkyo AVR's in a row. I must say it was kinda fun to not go into mental autopilot while setting the 4520 up.
Cheers,
JJ
01-28-13 07:14 AM
chrisexv6
Re: Need help with my Denon AVR-1912!!!

Quote:
oates wrote: View Post
3rd unit the receiver resets itself on a loop with with a flashing green light. Did a system reset and made sure all connections are taught.

Does anybody have anything else I can try before I ca Denon?

I've truly been patient with their sending of 3 units. Good customer service would be just getting my money back if I want it. With driving to drop off at fed ex, and disconnecting and setting up, I'll now have 6 hours into this thing. With a 3 month old and 4 year old at home I just don't have time for this. I'm sincerely disappointed with this whole experience and don't believe Denon has the capability to test their refurb units prior to shipping.

Every unit I've had a problem with started acting up after and hour of watching. Just turning it on once would lead you to believe it worked.
Sounds like you're cursed or something!

Couple things:

1. Have you tried connecting NOTHING to the unit and just turn it on to see what happens? If it goes into overload/protection/whatever while doing absolutely nothing, you've got a good case to go after Denon with.

2. Are you plugging it into the same receptacle each time? Probably just a remote possibility, but could their be something wrong with your mains wiring to that receptacle?
01-27-13 08:14 AM
oates
Re: Need help with my Denon AVR-1912!!!

3rd unit the receiver resets itself on a loop with with a flashing green light. Did a system reset and made sure all connections are taught.

Does anybody have anything else I can try before I ca Denon?

I've truly been patient with their sending of 3 units. Good customer service would be just getting my money back if I want it. With driving to drop off at fed ex, and disconnecting and setting up, I'll now have 6 hours into this thing. With a 3 month old and 4 year old at home I just don't have time for this. I'm sincerely disappointed with this whole experience and don't believe Denon has the capability to test their refurb units prior to shipping.

Every unit I've had a problem with started acting up after and hour of watching. Just turning it on once would lead you to believe it worked.
01-21-13 05:32 PM
Jungle Jack
Re: Need help with my Denon AVR-1912!!!

How much ventilation where the AVR is placed? How many inches of clearance is there above the AVR and is it placed in an enclosed AV Rack?
Unfortunately, if a refurbished AVR is purchased, it is exceedingly rare for a manufacturer to replace it with an A-Stock. Truly sorry for the issues you have experienced.
01-21-13 04:38 PM
oates
Re: Need help with my Denon AVR-1912!!!

This one kicks off and the red light flashes. The manual said it is a warning for overheating. There is plenty of space around the receiver and it sometimes kicks off before it really gets running.

The replacement is ok so far. I hear what you're saying about getting money back and it maybe not being possible. But at some point a company owes a customer for their time. In reality, based on them "testing" refurbs before they leave, I must be the luckiest cat out there. 2 that just happen to be the needles in haystacks of malfunctioning refurbs. I don't think so. Never again on a refurb. I should have just gone to Best Buy and spent half as much for a Yamaha that would have worked out if the box.

I have over 4 hours into this thing to just get a receiver that works (and I'm still not even sure I have one yet). This is between driving to reship units back and connecting and disconnecting, setting up etc.... At some point, a company should do the right thing and either a) give me my money back b) ship me a new receiver instead of a refurb.
01-21-13 12:18 PM
Jungle Jack
Re: Need help with my Denon AVR-1912!!!

Quote:
oates wrote: View Post


I just wanted to report back in that I'm now on my 3rd replacement of this as the 2nd has experienced an issue. I truly hope Denon can find a way to get my money back if this one doesn't work.
The chances of getting money back are amazingly slim. Another AVR? Most likely. What went wrong with the last one?
01-21-13 12:10 PM
oates
Re: Need help with my Denon AVR-1912!!!

Quote:
Jungle Jack wrote: View Post
Hello,
I really think this has been a matter of misunderstanding. One for which I am decidedly culpable. I really am sympathetic to your situation and purposely disclosed the website not to defend it, but to let other members know your experience.

I am so glad Denon has swapped out your 1912. Please believe be when I say I have maybe had 2 or 3 differences of opinion like this during my entire time here.
All the best,
J
I just wanted to report back in that I'm now on my 3rd replacement of this as the 2nd has experienced an issue. I truly hope Denon can find a way to get my money back if this one doesn't work.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!

 


For the best viewing experience please update your browser to Google Chrome