WaterFall Loopback Delay - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 5 Old 09-08-08, 10:03 PM
8068
Inactive
 
Posts: n/a
WaterFall Loopback Delay

Hello
My name is Brad and I am new here.
Before shooting any rooms with REW I have been running some tests. I am using the Art Dual Pre USB.
I will be using a Berringer ECM 8000 once I get the software all figured out.
Here is what I don't understand. When running tests with either my internal sound card on my laptop,
or using my external ART USB mic pre, when looking at a waterfall using a loopback connection no Mic.
I see all frequencies fall off at about 150ms. I would expect with a loop the fall off would be much quicker than that. As well I have tried this test using the Left channel as cal, with the measurement taken on the right. I assumed that would take the card delay into account. But it did not change readings.
I am using a intel dual core laptop with 2 gigs of ram on windows XP.
All other measurements look as I would expect.
One other question. My waterfall seems to run 200 HZ up to about 12khz. Is there anyway to alter this setting? Thank You for your response.
Brad
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-09-08, 06:52 AM
Elite Shackster
brucek
 
Join Date: Apr 2006
Posts: 7,514
Re: WaterFall Loopback Delay

The waterfall (like Spectral decay) is generated from the impulse response. The window selected (i.e. 300ms) is shifted to the right to create each slice. The slices are a function of the time selected (i.e 300ms = x30 10ms slices).

The waterfall, like any graph can have any axis selected that you wish.

Simply select the Graph Limits button and enter the vertical and horizontal axis.

Be sure to always use LOG as opposed to LIN mode selected by the Freq Axis button that is directly left of the Graph Limits button.

Be sure to use the REW HELP FILES..

WaterFall Loopback Delay-graph-axis.jpg

brucek
brucek is offline  
post #3 of 5 Old 09-09-08, 08:23 PM
8068
Inactive
 
Posts: n/a
Re: WaterFall Loopback Delay

BruceK
Thank you for your response. When I was running my tests I was aware of the option to
change the limits of the graph view. When I took my measurements the waterfall was only filling the
200 to 12k section of a larger graph. I'll experiment a bit more to to see how to change how the
unit samples and generates the the waterfall.
I am still not sure as to why a direct loopback would show that it takes 150ms to drop
30db. Is this processing delay?
Thanks
Brad
 
post #4 of 5 Old 09-10-08, 08:17 AM
REW Author
 
JohnM's Avatar
John
 
Join Date: Apr 2006
Location: UK
Posts: 6,705
Re: WaterFall Loopback Delay

Quote:
8068 wrote: View Post
I am still not sure as to why a direct loopback would show that it takes 150ms to drop 30db. Is this processing delay?
No, it is the effect of the window shape. If you changed the waterfall window type to rectangular you would see a very sharp drop once the impulse falls outside the window, but the sharp truncation of a rectangular window causes artefacts in the frequency response so window edges have profiles that taper gradually to zero, which reduces the windowing artefacts but for a waterfall has the effect of smearing out the drop in level.
JohnM is offline  
post #5 of 5 Old 09-10-08, 11:02 AM
8068
Inactive
 
Posts: n/a
Re: WaterFall Loopback Delay

John
Makes perfect sense.
Thank you for your response.
Wonderful job on the software!
As someone that has used Clio at work, I am quite impressed.
I'll stop back in the forum tonight and drop off a donation.
Brad
Reply

Bookmarks

Tags
delay , loopback , waterfall

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome