iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED - Home Theater Forum and Systems - HomeTheaterShack.com

Reply
 
Thread Tools
post #1 of 21 Old 11-02-11, 01:36 AM Thread Starter
Shackster
TagUrToast
 
Join Date: Oct 2011
Location: New South Wales
Posts: 45
iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Hi,
Just got a Behringer iNUKE NU1000, I plugged it in and turned it on with no speakers or inputs connected last night for about 5 mins, today plugged it in and was ABOUT to plug in some speakers, I turned it on before I plugged them in and it started for about three seconds and then a pop and it was off, the fuse seems to have blown (fairly certain of this).

When it did blow there was a 6.5mm to dual RCA connector plugged into channel 1 input (which I have checked to see if the connector is not internally shorting) but no cables connected to that.

I am 100% certain that the fuse is blown but am unsure of the cause or if anything else is damaged.

Is it likely that the fuse is just faulty or something? what should I do?
TagUrToast is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 11-02-11, 04:34 AM
Elite Shackster
 
Moonfly's Avatar
 
Join Date: Aug 2008
Posts: 7,142
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

The only way you can really figure the answer out to that is to replace the fuse and try again, and see what happens. I would let Behringer know as well, and let the dealer you bought it from know.
Moonfly is offline  
post #3 of 21 Old 11-02-11, 07:47 AM
Elite Shackster
 
Zeitgeist's Avatar
Jim
 
Join Date: Apr 2009
Location: Ohio
Posts: 2,116
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Hopefully replacing the fuse fixes it. Something does sound a little fishy though.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Zeitgeist is offline  
 
post #4 of 21 Old 11-02-11, 08:36 AM Thread Starter
Shackster
TagUrToast
 
Join Date: Oct 2011
Location: New South Wales
Posts: 45
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

I tried a screw in place of the fuse and it tripped the circuit breaker on my powerboard , I will have to get it replaced.
TagUrToast is offline  
post #5 of 21 Old 11-02-11, 08:37 AM
Elite Shackster
 
Zeitgeist's Avatar
Jim
 
Join Date: Apr 2009
Location: Ohio
Posts: 2,116
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Quote:
TagUrToast wrote: View Post
I tried a screw in place of the fuse and it tripped the circuit breaker on my powerboard , I will have to get it replaced.
Wow, that's daring!

Sorry to hear that it's bad


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Zeitgeist is offline  
post #6 of 21 Old 11-02-11, 08:42 AM Thread Starter
Shackster
TagUrToast
 
Join Date: Oct 2011
Location: New South Wales
Posts: 45
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

I wouldn't say daring, the fuse was a 7A fuse and my powerboard had a 10A circuit breaker (240v). The sad news is that I won't be able to pump my sub next week when it arrives

Also I only chose the screw because it fit perfectly and for some reason there are like burn marks around the fuse too, weird.

I didn't have much confidence in this amp when I got it because it is so light and now this, how inconvenient.
TagUrToast is offline  
post #7 of 21 Old 11-03-11, 02:00 PM
HTS Senior Moderator
 
fusseli's Avatar
 
Join Date: May 2007
Location: Colorado, USA
Posts: 1,921
My System
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Sounds like bad luck to me, chances of a DOA are pretty small with any big brand. Unless something "else" happened to the amp at some point...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
fusseli is offline  
post #8 of 21 Old 11-03-11, 02:42 PM
Elite Shackster
 
robbo266317's Avatar
bigbadbill
 
Join Date: Sep 2008
Location: Newcastle Australia
Posts: 5,771
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Replacing a fuse with a screw will probably void your warranty. Is it an internal fuse? ie did you remove the cover to get to it?

Silence is golden but duct tape is silver.

DIY completed:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
robbo266317 is offline  
post #9 of 21 Old 11-09-11, 11:21 PM Thread Starter
Shackster
TagUrToast
 
Join Date: Oct 2011
Location: New South Wales
Posts: 45
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

They are sending a replacement today
Hopefully I can finish my sub this weekend.
TagUrToast is offline  
post #10 of 21 Old 11-10-11, 10:35 AM
HTS Senior Moderator
 
fusseli's Avatar
 
Join Date: May 2007
Location: Colorado, USA
Posts: 1,921
My System
Re: iNuke NU1000 Fuse blow on second use NO SPEAKERS CONNECTED

Good, sounds like something that they should replace under warranty. No need to tell them about the screw though


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
fusseli is offline  
Reply

Bookmarks

Tags
blow , connected , fuse , inuke , nu1000 , speakers

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome