ep2000 question - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 6 Old 11-05-11, 10:48 AM Thread Starter
Shackster
 
Join Date: Jun 2011
Location: baton rouge, la
Posts: 13
ep2000 question

i just received my ep2000, to power my 2-sealed mfw-15s. i have a sony 10"er at the moment. im still waiting on my bfd, but just to see how it sounds i unplugged my sony and hooked up the ep2000 into the denon receiver with an rca to xlr plug and speaker wire to my two subs. but when i turned it on, they hardly make noise. i tried with teh clip limiter on and off i have the mode on parallel cause im only using one input. i have the filter turned off on it. i didnt rerun audyssey yet, and i turned the sub channel to +6. i have hooked one of my subs up to my sony amp and it sounds great, but the ep isnt doing anything. the yellow signal light is coming on but its hardly making a sound. it should be rocking, any suggestions?
fridge011 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-05-11, 09:35 PM Thread Starter
Shackster
 
Join Date: Jun 2011
Location: baton rouge, la
Posts: 13
Re: ep2000 question

Has this happened to anyone?
fridge011 is offline  
post #3 of 6 Old 11-06-11, 06:27 AM
HTS Senior Moderator
 
Wayne A. Pflughaupt's Avatar
 
Join Date: Apr 2006
Location: Corpus Christi, Texas
Posts: 9,166
Send a message via Yahoo to Wayne A. Pflughaupt
Re: ep2000 question


Just to clarify - for parallel mode, dip switches #4 and #5 should be set to the right, and #6 and #7 should be to the left.

Did you try adjusting the EP’s gain controls?

It might be better to use standard RCA to 1/4” TS cables rather than XLR.

Also, if you're using Speakon connectors make sure they are wired correctly. And double check the polarity on your two subwoofer speaker wire connections, including internally (inside the box itself). If one of them is backwards it’ll suck the life right out of your output.
Regards,
Wayne



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Wayne A. Pflughaupt is offline  
 
post #4 of 6 Old 11-06-11, 08:32 AM
New Member
ma7rix13
 
Join Date: Sep 2009
Location: PA
Posts: 3
Probably a line balancing issue.
ma7rix13 is offline  
post #5 of 6 Old 11-06-11, 10:53 AM Thread Starter
Shackster
 
Join Date: Jun 2011
Location: baton rouge, la
Posts: 13
Re: ep2000 question

Alright I got it. It mist have been the cable. I used a 1/4 and it's working fine. I can't wait till I get my bfd in and set up so I can bug y'all with bfd questions. Lol. But really I'm reading up on it a whole lot and hopefully it wont be too bad. I've been waiting to watch a few movies till I get everything set up. Thanks for your help
fridge011 is offline  
post #6 of 6 Old 11-06-11, 04:11 PM Thread Starter
Shackster
 
Join Date: Jun 2011
Location: baton rouge, la
Posts: 13
Re: ep2000 question

It seems when i play blu rays they hit hard, but when I watch cable or play pandora through ps3 they hardly make a noise
fridge011 is offline  
Reply

Bookmarks

Tags
ep2000 , question

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome