Hum and poor output - Behringer EP4000, Rolls MB15b, Yamaha RX-V667 - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 1 Old 04-03-15, 06:11 PM Thread Starter
Shackster
Brad
 
Join Date: Apr 2009
Location: Frederick, MD
Posts: 19
Hum and poor output - Behringer EP4000, Rolls MB15b, Yamaha RX-V667

Receiver: Yamaha RXV663 - http://usa.yamaha.com/products/audio...v663_black__u/

Amplifier: Behringer EP4000 - http://www.amazon.com/gp/product/B00...?ie=UTF8&psc=1

Line Converter: Rolls MB15b -http://www.amazon.com/gp/product/B0002IL4B4/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Cables: http://www.amazon.com/gp/product/B00...?ie=UTF8&psc=1

I wanted to run dual subs so I took the plunge and bought an EP4000 along with a pair of RCA to XLR cables. After plugging everything in I thought the input phase of the amp was defective because even with the gain at max no sound was coming out.
After further research, and toggling dip switches on the amp, someone from Parts Express recommended that I buy a line converter. I ordered the Rolls MB15b from Amazon along with male/female XLR cables.

I plugged everything in today like this:

Receiver Subwoofer Out RCA -> Rolls MB15b -10db in -> +4db XLR Out -> Behringer XLR input

Behringer pins are as follows:
Right - 1,3,8,10
Left - 2,4,5,6,7,9
gain on the behringer turned all the way up

Receiver side crossover set to 80Hz, receiver's subwoofer level turned all the way up, level on the Rolls turned half way up, the subwoofers are audible but very weak and I'm hearing audio well above 80Hz through the woofers. An audible hum is present that seems to increase exponentially when turning the level up on the Roll's. As well, with the level at 100% on the Roll's, Behringer at 100% gain, Receiver's subwoofer level at 100% my pair of Cerwin Vega VMax 15.2 woofers don't move or play even close to the same level as when driven by a cheapy BASH500 plate amp.

Not sure what is going on, any help is greatly appreciated as I'm about to return the behringer and rolls in favor of something like the Dayton SPA1000.
MY99 2.5GT is offline  
Reply

Bookmarks

Tags
behringer , ep4000 , hum , mb15b , output , poor , rolls , rxv667 , yamaha

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome