what am I doing wrong? No sound in digital channels: Panasonic TV & home theater - Home Theater Forum and Systems - HomeTheaterShack.com

 
Thread Tools
post #1 of 4 Old 06-14-14, 08:20 PM Thread Starter
Shackster
Maurice
 
Join Date: Jun 2014
Location: L.A.
Posts: 6
what am I doing wrong? No sound in digital channels: Panasonic TV & home theater

I moved and can't get sound when watching digital channels at the new place. I connected my TV to my home theater according to the manuals but can't figure out what I'm doing wrong. Please help. Here's my set up:
Panasonic TC-P50U2 TV
Panasonic SC-BT230 HT (home theater)

Details:
-HDMI cable going from the TV's AV IN "HDMI 1 (ARC)" port to the HT's AV OUT "HDMI (ARC)" port
-Optical digital audio cable going from the TV's "Digital audio out" port to the HT's "Digital audio In" port # 1
-No cable box, coaxial cable plugged directly to the TV's "Antenna Cable In" port
-HT menu to select source: "Input Select" --> "ARC"... no digital sound. Same when selecting "AUX", "Digital In 1" or "Digital In 2".
-I do get sound in digital channels if the TV is not connected to the HT.
-When HT is connected to TV the image is fine in digital channels but there's no sound. No problem when watching analog channels or when playing DVDs/blue rays.
-Had no problems before the move, only difference is that I had a DVR at the old place. That shouldn't matter, or should it?

I have gone through the manuals of both the TV & HT but I'm obviously not techie enough to figure it out.

I'm thinking is just some setting on the TV or HT menus, but for the life of me, I can't figure it out. Sorry if this is a stupid question, please be kind on me and let me know if there's more info I need to provide.

Thanks!
MauriS69 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-15-14, 12:37 PM
Shackster
 
eyespy39's Avatar
eyespy39
 
Join Date: Aug 2013
Location: Germany
Posts: 32
My System
Re: what am I doing wrong? No sound in digital channels: Panasonic TV & home theater

Just a guess: did you set anything at your TV or HT concerning HD-audio format, e.g. DTS or Dolby or Bitstream or PCM? To me, it seems to be a data format compatibility issue rather than a wiring issue. Have you turned Viera link on?
Then, there maybe a setting in your TV and your HT, too, where you can explicitely specify that sound is played via TV speakers or via HT/AVR/Amp. Have you checked that?
On the TV, this is set via VieraLink Control->Speaker output.
Usually, you don't need to select an input port. It should be enough to turn your Home theatre on whith your TV already running. When ARC is wired correctly, and when those output options TV vs. HT are set correctly, sour TV ought to mute and your HT ought to switch to the appropriate input. If so, your wiring appears to be correct and the problem seems to stem from the mentioned Audio format problems.
The TV's manual advices in case of sound problems to set the Amp or HT Audio digital input to "Linear PCM"

Hope to have helped…

Last edited by eyespy39; 06-15-14 at 12:50 PM.
eyespy39 is offline  
post #3 of 4 Old 06-17-14, 03:18 PM
Elite Shackster
 
rab-byte's Avatar
Mr. Rabbit
 
Join Date: Feb 2011
Location: Baton Rouge, LA
Posts: 1,320
ARC needs HDMI control turned on both in the TV and the AVR. I assume your AVR also supports ARC.

Opting to just do optical may be a more solid fix because HDMI-CEC controls can be funny sometimes; especially if you're using a universal remote like a harmony.

If you go with optical you may need to turn off the TV speakers and set them to external. Then you'll just set the receiver input to optical. HDMI CEC would require you to put the TV to the TV input and the AVR should automaticity switch to ACR.
rab-byte is offline  
 
post #4 of 4 Old 06-18-14, 09:42 PM
Senior Shackster
BJ
 
Join Date: Jun 2006
Location: St. Paul, Minnesota
Posts: 201
With hdmi and arc there should be no need for the optical cable, so I would disconnect it as it may cause more confusion trying to troubleshoot. The make sure you have TV and receiver settings correct for arc. Note many devices require you to power cycle both devices after making changes to these settings before they take effect. If you can't get that to work then add your optical cable back in and turn off arc, maybe using different inputs and outputs on the devices as often times only one supports arc. You may need to tell the receiver to use the optical audio rather than hdmi.
primetimeguy is offline  
Reply

Bookmarks

Tags
channels , digital , home , no digital sound , panasonic , sound , theater , tv , wrong

Quick Reply
Message:
Options

Register Now




PLEASE COMPLETE ALL REQUIRED FIELDS BELOW... THANKS!

REQUIRED FIELDS ON THIS PAGE
YOU MUST COMPLETE ALL OF THESE

Username
Password
Confirm Password
Email Address
Confirm Email Address
Random Question
Random Question #2




User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
PLEASE READ BELOW PRIOR TO ENTERING AN EMAIL ADDRESS!

ATTENTION!

YOU MUST ACTIVATE YOUR ACCOUNT!

Activation requires you reply to an email we will send you after you register... if you do not reply to this email, you will not be able to view certain areas of the forum or certain images... nor will you be able download software.

AN INVALID EMAIL ADDRESS WILL CAUSE YOUR ACCOUNT TO BE DELETED!

See our banned email list here: Banned Email List

We DO NOT respond to spamcop, boxtrapper and spamblocker emails... please add @hometheatershack DOT com to your whitelist prior to registering or you will get nowhere on your registration.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML is not allowed!
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


For the best viewing experience please update your browser to Google Chrome