Home Theater Forum and Systems banner
fuse
1-13 of 13 Results
  1. Pioneer
    Hi all, i have a Pioneer a-205 amplifier, recently i power it up and nothing turn on, after some diggin i found that the primary winding of the transformer is open, i suspect that is the thermal fuse, because the last time was working ok, and the next nothing, no problems of any kind earlier...
  2. Sony
    Hi Leonard and all, All my family and friends who wanted big screens have them now 8-> and I've been working a lot so I haven't been big screen playing lately. Tonight I'm working on a Sony KP65WS510 and I found PS5001 is bad. It's a pico fuse over on the G Board and the manual says it's a...
  3. Home Audio Subwoofers
    I have a Boston Acoustics VS Series VPS210PF Subwoofer and today when I got home I turned it on and nothing happened, I'm just wondering what it could be and how I could fix it.
  4. DIY Repair and Maintenance
    Hello, Fellow Home Theater Shackers, As you might have guessed Im new to the forum, and after trolling the site looking for an answer to my TV woes , have decided to have a go a posting to try and get to the bottom of my Problems. I have an LG rear Projection TV that I have had for some...
  5. Subwoofer Amps | High Pass Filters
    Hi, Just got a Behringer iNUKE NU1000, I plugged it in and turned it on with no speakers or inputs connected last night for about 5 mins, today plugged it in and was ABOUT to plug in some speakers, I turned it on before I plugged them in and it started for about three seconds and then a pop and...
  6. Home Audio Subwoofers
    Hi Guys and Gals, I have an older subwoofer and it looks like the fuse is blown. It is a 0.63A/250V or as it says on the Sub 650mA/250v. I went to The Source (radio shack) and the guy told me to just by a .5A/250 as they did not have the .63 or 650mA type. As soon as I plugged the sub in the...
  7. Sony
    My KP53XBR45 Sony (about 15 years old) stopped working(press power button, a single flash from the little light and ya hear a click in behind, thats it) a few months back, after finding some google info i too it apart and found a 3.15 amp fuse blown at "F1602" (there are two fuses there, the...
  8. Sony
    Ok well my sony hd tv had convergence issues where all of the colors would not allign once I went into convergence setup. I read online and found out I could check the fuses / resisters and replace the IC chips. I did this and it worked beautifully for about 6 months. Now round 2. One...
  9. Toshiba
    Hi Guys, My 21 year old poor college kid son got a Toshiba TP48D50 given to him. It was free because it has a convergence issue. I did some research and found it's normally caused by the stk chips and I even found a Toshiba Service Tip sheet to follow. The TV info: Toshiba 48", Model...
  10. DIY Repair and Maintenance
    Icaillo, I need pico fuse (protector 491010t52) hitachi part azoo421m. is this just a 10A pico II? it has a solid black line on each side of 10K in gold lettering. I ordered it from encompass a month ago and have become completely fed up with them. I ordered a trs from them that cost me $8...
  11. Sony
    Hi lcaillo (hat off) Can I use the 5A/125v pico fuse from Acme-sales as a sub to PS5001(P/N 1-533-597-31) on th G board? I think yes but I would feel more comfortable if a guru like you says ok, :heehee: I'm about to order a pair of STK392-570s and this fuse from Acme. I acquired this TV...
  12. Home Audio Subwoofers
    I'm SPL-1200R owner. Today I have found that a front blue LED doesn't shine. I have checked the power cord by a pocket avometer and it seems like rupture of input power circuit. In other words it seems that there is necessary to replace safety fuse... Anybody could council me something ...
  13. Sony
    Can anyone tell me where the thermal fuse is located on a KDF60WF655 Thanks for any help on this
1-13 of 13 Results
Top