Home Theater Forum and Systems banner
left
1-12 of 32 Results
  1. DIY Repair and Maintenance
    Recently, for no particular reason, the left channel on my amp has stopped working. I've checked the speaker cable and the speaker and these are working fine. It a complete mystery and I was hoping some could enlighten me as to why this is happened.
  2. Hitachi
    Hey guys, I've been reading these posts to see if I can get a handle on my problem here. I picked tv up used a few months ago for my father to replace his old set. After a few weeks he heard a loud snapping sound and the TV wouldn't come on but would blink the blue light seven times. So I...
  3. Onkyo
    Hey guys, I've had my Onkyo receiver for a few days now, and just tonight I'm getting static out of the left speaker only. Now, I did some research before posting this. I checked my connections, everything's good there. I then ran the speaker wire all the way out (taut) so it wasn't touching any...
  4. Video Game Systems | Video Games
    Remedy Moves Alan Wake to Multiplatform, but PS3 is Left Unsupported Typically, the PlayStation 3 holds its own when it comes to exclusives, but there was one game that came out in 2010 which would have fit perfectly on the console but never made it: Alan Wake. It was just announced that...
  5. Home Theater Receivers | Processors | Amps
    Looking for suggestions. I have a marantz Sr 8000 that I have really enjoyed over the years. Unfortunately, I can only get the left channel to play in source direct mode when using the RCA in puts. The 5.1 works great with optical inputs. But, cd, tape, anything RCA (even front aux inputs)...
  6. Home Theater Receivers | Processors | Amps
    Hey guys, so lately my left channel has been not working but usually I can turn it off then back on or standby it and unstandby it and it would be ok. Well today it is not working almost entirely. Is there a likely component that is going bad for this to be happening?
  7. Audio Processing
    I've run a few calibration cycles and each one stops as soon as it tries to test the left rear surround. When listening to music in the all channel stereo mode and when using internal pink noise, that channel sounds fine and is properly trimmed. All of the other channels (except for left...
  8. New Member Introductions
    My Name is Mike I hail from Seattle but live current in St Louis Mo. I have a diverse background in building trades (not cabinet building alas) and years in electronics ans computers in my trade, I am A BAS Controls programmer/technician I have build many speakers over the years and a few subs...
  9. Home Audio Subwoofers
    I am a bit confused. Do I need a 8 ohm or a 4 ohm sub? Right now I am running a ADCOM GFA-545II to my right and left channels. They are (in each box) 1 dayton 7" driver and 1 dayton silk dome tweeter and custom crossovers in each box. All the 4 speakers are 8 ohms. I want to purchase Dayton...
  10. Electronic Processing/Equalization Devices
    Since , I dont use the left and right filter sets simultaneously, would it be possible to use the left bank for one filter set and the right bank for another filter set thereby effectively doubling the number of filter sets available for use? For example I can store a filter set without house...
  11. System Setup and Connection
    Hi, I am new. I have a Onkyo TX-SR607 receiver paired with two JBL HLS610 reference speakers. I set up my system several weeks ago, but only yesterday did I start having this problem. The left channel output is not putting out the same power as the right channel. I have tested both speakers and...
  12. DIY Repair and Maintenance
    Hi There keen Shacktser Techy's.. I have a problem with my DIY 2ch Cahnnel Amp. It's the complete kit from Silicon Chip, the Ultra-LD Stereo Amp (Altronics kit # 5155). I've had it for a while and it's been working beautifully up until a week ago.. It's used to power HF drivers in a bi-amp...
1-12 of 32 Results
Top