Home Theater Forum and Systems banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Behringer processor fault and fix: DCX2496

I am posting this just in case it can help someone searching this forum in future. This info may already be in some other part of this forum, in which case my post just reinforces the statistics of the fix.

My DCX2496 suddenly developed a fault - when turned on, it would show a blank screen and faintly flicker leds on Input A and output 1.

What I did:
1) I first tried a factory reset (power-on while holding both Page buttons down). Had no effect.
2) Heating and cooling cycles had no effect (surprised me)
3) I then opened the lid, and pulled and pushed at the connectors of three ribbon cables. None of the connectors "felt" loose.

I toggled all ribbons but only managed to lift one connector off its female socket, and then replace it.
I closed up, switched on, and for some reason it functioned again. Had to re-enter my config data.

I have since found at least a couple of forums on the internet where a poster related a similar experience, although in some cases nothing brought it back. One user re-started his by connecting it to a PC with an RS232 connector via a USB to RS232 converter. Can't imagine why that fixed it, but there you are.

So if you get the same symptom on a DCX2496, you have something to try. Wild guess - the connectors may not be the highest quality and therefore a pin may have made marginal contact with its seat, which was restored by just handling it.

Despite saying that, when originally launched the product represented quite a powerful and versatile piece of digital processing at a very low list price, so maybe Behringer had to cut corners.

Post "repair", my DCX went through a few long duration sessions and is working ok so far.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I'm not sure if I know anyone with a DCX who hasn't had similar issue, including me :smile:
AJ, in that case can you set my mind at ease:

1) Did you use the same simple "fix" or is there a better trick

2) Did the fix last or can the problem recurr?

Thanks
 

·
Moderator
Joined
·
1,662 Posts
Hi Mark,

These issues with the DCX have been around for 10+ years. I recall all the self fixes on DIY forums, Yahoo groups, etc. from back then, reseating the cables, making sure they were off chassis, etc, etc.
When it occurred with mine, I contacted Behringer, took it to an authorized repair center (here in Tampa) and had it fixed (supposedly new cables). It worked for a few months...and recurred.
Mine has been sitting in storage now for a good 8+ years, maybe more ;-).
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Bummer, so it may black out again at any time and really can't be relied on.

Thanks for the info AJ. From what you say it sounds a bit like a dud (and Parts Express is currently still selling it).

May have to start looking for something else. The main reason I got a DCX2496 in the first place is because I wanted the choice of crossover slopes from 6 to 48dB/oct, and have some parametric equalizers available in the same box. Without breaking the bank.

Anyone happens to read this post and aware of another reasonably priced crossover product with a good range of slopes (with or without PEQ), I would appreciate you mentioning it.
 

·
Moderator
Joined
·
1,662 Posts
I also have bad luck.:smile:
I would use your DCX if it works.
A popular option is the minidsp2x4 series, available at both Madisound and Parts Express.
Yes, it requires connection to computer via usb for setup, but once done it works off either analog or (with HD) digital input, with analog outs. A pair of 2x4s gives you a stereo 4way..and is still less than DCX
 
1 - 6 of 6 Posts
Top