Home Theater Forum and Systems banner

1 - 8 of 8 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
O.K., so, Got the BFD installed, verifed FW (1.4), power up and regardless of what mode I put it in all of the red front level LEDs blink in sequence. I've tried powerup with no inputs or outputs connected, in 1 / out 1 connected, same result. Also, the stor light randomly blinks.

This is the second one I've gotten as the 1st one would just lock up and become totally unresponsive at the front panel. Unfortunately that one I can't return for credit as it sat in a box for 3 months before I got to it. :doh:

Are these really that bad or am I 0 for 2 from the same local dealer ? :scratch:

Thanks

J
 

·
Registered
Joined
·
7,514 Posts
power up and regardless of what mode I put it in all of the red front level LEDs blink in sequence
The RED LEDs blink if you enable each filter in the PA mode or OF mode? If so, there's a fault.

They are a cheap device, but two in a row seems like outrageously bad luck...

brucek
 

·
Super Moderator
Joined
·
9,252 Posts

Unfortunately that one I can't return for credit as it sat in a box for 3 months before I got to it. :doh:
You should still be able to get it repaired or replaced under warranty, right? Getting two bad ones back to bac, they might be willing to make some concessions for you - complain to the customer service manager.

Regards,
Wayne
 

·
Premium Member
Joined
·
6,711 Posts
The LEDs flash when in feedback destroyer mode. The store LED flashes if a setting has been changed but not saved. Set all the filters to PA and see if it stops the flashing.
 

·
Registered
Joined
·
15 Posts
Same thing happening to me. Have set manually and leds won't stop blinking. I set 3 filters up on rotary dial 5. 3 lights are solid and rest continue to blink. Have pressed store twice per instructions. And am in PA mode. Should in/out be blinking or constant when adding manually?
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Bah, I guess for $99 I shouldn't expect much but cmon...the second one just failed, shuts down for no apparent reason. Off to return it now -- for a refund. The 1st one has to get shipped to manufacturer and then is getting sold off, fast.

Thinking about going with a std parametric eq and doing this the old-school way, any recommendations ?

J
 

·
Super Moderator
Joined
·
9,252 Posts

You can get used models from Rane, Ashly, dbx, Symetrix etc. at affordable prices on eBay. Do a search on "parametric" from the home page and you'll probably find other stuff, too. Another good option for a digital parametric is a vintage Yamaha YDP2006. Or you might try a used BFD. They can't sell one that doesn't work without disclosing that information, so your assurances of getting one that works is excellent. :T

Regards,
Wayne
 

·
Registered
Joined
·
7,514 Posts
I set 3 filters up on rotary dial 5. 3 lights are solid and rest continue to blink.
Yes, that's normal. You have to set any unused filters to 'OF' mode before they are turned off. It's usually best to set all filters to 'OF' and then start from there.

brucek
 
1 - 8 of 8 Posts
Top