Home Theater Forum and Systems banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi All,

Beginning in August, I began doing extensive research on budget subwoofers. Two subwoofers peeked my interest and eventually lead me to this site . NXG technology bas 500 and the Cadence CSX-12mark II. After careful consideration my 1st choice was the NXG bas 500, but as luck would have it, its no longer available. So I move on to my 2nd choice the Cadence CSX-12markII. It was also hard to find but I was able to order it from
Ebay. The Sub was received 12/06, and intergrated into my home theatre system which consist of PSB image:T65,C60,S50, AND Marantz avr 6005. The markII replace a Klipsch synergy Sub 10 (which works fine) the CSX was suppose to be an upgrade. My system has high quality cables and wires with banana plugs. Installation was quick, just power off everything and plug in the CXS 12, and power back on. Now let the sytem play awhile to break in, but there is a problem!!!!!!. My main left/right channels are not out-putting and sound.
After further inspection they are blown. How is this possible ? I read this about a guy setting up a JBL es250, and thought he was crazy but now my main sythem down. The 6005 is 7.2 receiver so I am using the rear surround channels to power the fronts until repairs can be made. If anyone can shed some light on this matter it would be greatly appreciated

jbgene
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
The speakers are fine. Its the main left and right channels of my marantz 6005, that went out.
I sent and email to the seller, and they responded by saying return the Sub to Cadence and the would give a full refund.
 
1 - 3 of 3 Posts
Top