Home Theater Forum and Systems banner

21 - 37 of 37 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #21
Thanks brucek,

So to recap, I set my output/wave volume to 1.000 and reduce my amps volume. Should I change the imput volume too?

The BFD was second-hand and had firmware 1.0, I think I am right in assuming it is ok ie not the 1.3 version.

Getting there...

Graham
 

·
Registered
Joined
·
140 Posts
I have a longish room, 21 x 12.5ft x 10ft ceilings. It has a bay with large windows and blinds. It's rather echoey now the curtains are gone. There are a couple of beds in there as it's our bedroom at the moment. There is a side table over the sub to hide it. This is one of those marital compromises, so sticking it in the middle of the room is probably not going to fly.
According to a room mode calculator the main modes in your room are:
26.9
45.2
53.8
56.5
80.7
90.4

Which is more or less borne out by your room response. Depending on how much grunt and headroom you have with your sub, and after following Brucek's suggestions on getting the right input levels into the BFD, I'd look at raising the volume on the sub a little to raise the troughs, EQ the "higher" levels back to a flat line (or house curve) and perhaps put a hint of a boost (no more than 3db) on the BFD for the troughs. Every little helps!

I nearly set up my first set of filters, but despite setting up the BFD to accept midi control, it appears to send it via REW, but not a dicky bird from the BFD. Nothing at all flashes. That's when I leave it on channel 4. Maybe I am all too eager to blame the card, but I did try a couple of times. It was set up for the left channel, so it's not that.
Have you switched on the Midi capabilities on the BFD? This is done via the buttons (the REW instructions have the procedure) and is "lost" if power is turned off at any time. So if you turn off the BFD at any time, the default state is MIDI - OFF.

Have you selected your sound card's MIDI capabilities in the Control Panel, Sounds and Audio Devices, MIDI Device (under the Audio tab)?

Also, I have found that the labelling of MIDI-IN and MIDI Out can often mean the opposite. Swap your cable around as another option!
 

·
Registered
Joined
·
34 Posts
Discussion Starter #23
Thanks Bob,

Some useful suggestions there - I will certainly give it a try when I get a chance.

Cheers.

Graham
 

·
Registered
Joined
·
7,514 Posts
So to recap, I set my output/wave volume to 1.000 and reduce my amps volume. Should I change the imput volume too
You're confusing two things here. Forgetting about REW for a minute (remember it's just a tool to help set the filters in your BFD).
You need to understand your system levels and the use of the BFD before using REW. Re-read the stuff below and get the system levels set first.

The input level to the BFD is totally contolled by the receivers volume control and trimmed somewhat by the receivers subwoofer speaker trim adjustment. We are simply trying to ensure the BFD gets an optimum a signal as possible. This means once the trim level is set for the subwoofer out of your receiver, then after that the volume level of the sub is best adjusted with the subwoofers own amplifier (as opposed to touching the trim again).

So, bypass the BFD (IN/OUT GREEN LED flashing and leave it that way for now) and setup your speaker levels with the receivers test tones (including the sub trim and subwoofer amps volume) as you normally would do.
Then put in a bass heavy movie and turn it up to the loudest you would ever use the system. If the BFD LED's are clipping in the RED, then turn the subwoofer trim down and turn up the sub amp to compensate. If the LEDs are not clipping, then turn up the trim to get the yellow LED on and turn down the sub amp to compensate.
There, now the sub trim is set for your system. Don't touch it again. The subs level will now be controlled by the sub amp volume (when necessary to change its balance against the main speakers).
You can put the BFD back on with the IN/OUT GREEN LED ON for filters engaged or OFF for filters disengaged. The flashing Green LED is filters off and the VU meters monitoring the input as opposed to the output level.

Now your system speaker levels are balanced, you can hook up REW and use it. The only system volume you'll touch is the Main Receiver Volume control. Don't touch the sub or the trim for now. Just the receivers main volume control.

Start the Check Level Routine and Set the REW output/wave volume to 1.000 and then set the receivers volume control to reach 75dB on the RadioShack meter.
Now set the input volume control on REW to the correct VU level.

Then do the Calibrate SPL routine.

Then do the Set target Level routine.

Then carry on with the measure...


brucek
 

·
Registered
Joined
·
34 Posts
Discussion Starter #25 (Edited)
Well, after literally hours of printing out the help files and pouring over then one by one, I have made a discovery!

The line-in choice should have been stereo mix. This makes a whole lot more sense now. But it's two forward and one back I think.

I have this as a measurement and I have NO peaks. I did think that I had done all the sound levels correctly. To be honest, it's such a poor 15in lcd monitor that I can't make out which line means what. It's also on the floor, so I am peering at it on my hands and knees!

I can't do much now as it's late, so would much appreciate any thoughts to fast-track me to filter heaven!



Thank you.
Graham
 

·
Registered
Joined
·
7,514 Posts
The line-in choice should have been stereo mix
Nope. Set it back to line in.

Notice how the purple line is the exact inverse of the meter calibration file?

You have an internal loopback monitor turned on in your soundcard software........... The output is looping back to the input in the soundcard itself.

brucek
 

·
Registered
Joined
·
34 Posts
Discussion Starter #27
Ah, bother!

Before I got as far as the check level - all was going swimmingly until I came to check levels, just before producing the chart. It had virtually no input volume - something like -53. Literally everything else checked out up to that point. I got an error message saying to check my cables and input/output settings. That is when I went back and selected something else other than the line-in. I had the card set to stereo, so figured I had cracked it. Everything went fine until the final measurement.

Back to the drawing board - thanks again.

Graham
 

·
Registered
Joined
·
34 Posts
Discussion Starter #29
I assume you're using stereo connectors on the line-in and line-out plugs?

brucek
Yes, the double ones like the pic in the help files. I'm just using the red (right) channels.

I am determined to get to the bottom of it. It's good to have you on my side though.

Graham
 

·
Registered
Joined
·
7,514 Posts
virtually no input volume
Are you using a standard RCA connector on the Radio Shack meter?

Can you plug the Radio Shack meter into the AUX or CD input of your receiver with a standard RCA to RCA cable and sing... it's a microphone. Does it work?

brucek
 

·
Registered
Joined
·
34 Posts
Discussion Starter #31
Are you using a standard RCA connector on the Radio Shack meter?

Can you plug the Radio Shack meter into the AUX or CD input of your receiver with a standard RCA to RCA cable and sing... it's a microphone. Does it work?

brucek
Hi brucek, yes it is standard rca connectors. I can't sing : ), but CAN get sound out of the mic. To be honest, I was able to meet all the criteria of the software - and it was as expected - all the way up to the measure panel when I was asked to check the levels. That is where I get the -53 reading and the warning it is much too low. The check of levels in the setting panel was fine.

Tis a mystery.

Graham
 

·
Registered
Joined
·
7,514 Posts
all the way up to the measure panel when I was asked to check the levels. That is where I get the -53 reading and the warning it is much too low. The check of levels in the setting panel was fine.
Ahhh, there's something you failed to mention - that the Check levels was OK (in Check Levels) and not in the Measure routine.

That's because the Check Levels routine in the Measurement screen and the Check Levels routine in the Settings screen use different values to generate the pink noise.

The Check Levels routine in the the Settings screen uses the fact that you have the Check/Set levels with Subwoofer pull-down selected to generate its test noise.

To double check and verify that the end frequency of the sweep that you have selected in the Measurement panel matches that subwoofer setting, its' Check Level routine uses the end frequency as the pink noise hi-limit cutoff. So if you had 20KHz as the end frequency to measure for your sweep, you can see how the pink noise would be different (between the two Check Levels) and as such the low level signal you're experiencing.

Set the End Frequency in the Measurement panel to 200Hz..................

End_Sweep_Freq.jpg

brucek
 

·
Registered
Joined
·
34 Posts
Discussion Starter #33
Success!!!

Thank you brucek. I changed back to line-in and it all seemed to work. The 200 figure in your previous post was there and still is, so I don't really understand what had changed. Maybe just changing the input back to line-in made it register in some way?

Malice, you were right about the midi connections needing reversing - never would have thought of that, so thanks!

Anyway, Just to confirm, here are my graphs.

before filters.



with filters applied (not manually adjusted).



and with the filters and the main speakers.



It seems that I am going to have to increase the sound level on the sub. Is this via the subs volume control?

Then I can add a house curve and add a few filters to push up the dips by 3db or so - is this correct?

Many thanks for your help and thoughts on this.

Graham
 

·
Registered
Joined
·
7,514 Posts
It seems that I am going to have to increase the sound level on the sub. Is this via the subs volume control?
Yes. Also, if you want more of the plot considered for filter recommendation, then before pressing the Find Peaks button, manually lower the set target thumbwheel to include more of your plot above the target line.

add a few filters to push up the dips by 3db or so - is this correct?
Adding gain filters is not a great idea. Your dips seem to be sharp and likely you won't hear them. Better to raise the sub level as you've already figured out (and then cut a bit more on the new peaks)...

brucek
 

·
Premium Member
Joined
·
6,711 Posts
Did you go through the "Optimise PK Gain & Q" step after assigning the filters? If you dd, you may want to manually tweak (increase) the bandwidths for filters 1, 2 and 3 to get a smoother corrected result, use "Adjust PK Gains" afterwards to get the levels correct.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #36
Thanks John,
I think you are quite correct - although this is 'old' now. I have had another crack and found it also works better with the phase at 180. I added a house curve, increased the subs level and hammered down the peaks a little more heavily. This one was just to get some filters in to sample what could be achieved. I must say, initial real-world results are quite impressive - I am really beginning to appreciate what the bfd is doing for me. It is quite an expense on top of the sub, including all the extras, such as soundcard and cabling, not to mention the learning curve, but it has all been very worthwhile. In fact, I am only now getting the value out of my expensive subwoofer!

If I ever get the luxury of a couple of hours to myself, I would love to have a real good play and share my results with you guys. REW really is an excellent piece of software. Being able to see what is going on is a revelation.

Graham
 

·
Registered
Joined
·
140 Posts
Without a BFD and REW I'm sure by now I would either have had to have sold my sub, or at least have sold the missus. The sub without EQ and SWMBO were not destined to share the same floor space!!

Bob
 
21 - 37 of 37 Posts
Top