Home Theater Forum and Systems banner

Cannot generate waterfall

3912 Views 20 Replies 7 Participants Last post by  JohnM
Has anyone seen an issue where waterfalls cannot be generated? I took some measurements today (REW 4.11, JRE 1.6.0_13) and I cannot generate any waterfalls for them.

When I go to the waterfall tab, I see the measurement file I had opened right above the “overlay” with the check next to it. The file I had opened only had one sweep in there and it also has a check mark next to it but both of them are grayed out. It is also like this on the “Spectral Decay” tab.

All other tab have it to where I can check-uncheck what I need.

Thanks, James
1 - 20 of 21 Posts
it also has a check mark next to it but both of them are grayed out
It will remain grayed out until the waterfall is generated.

Click the 'Generate Waterfall' button in the bottom right hand corner of the Waterfall page.

Each measurement has to have the waterfall generated.


I will try again with the button. Right now it jsut shows the progress window but does not move. If I recall from the previous version, each sweep could be checked or unchecked before needing to click the generate waterfall button. Also, on the last version, it was pretty quick, click the GW button and the waterfall was there.

One other thing, not sure it matters but just in case. Next to the file which is labeled "July 19 14:26:01" it shows -180.db

What I am looking at.

See less See more
it shows -180.db
That's the level at the cursor position. It's not important if the cursor is located at a position outside the measurements bandwidth.

Why do you have the vertical scale of the waterfall from -8to 48dB? The signal level will be around 75dB, which is above the level you have set.

Does the frequency response and impulse response look OK?

Let's see them both.

Bruce, for the graph setting I must have been moving it around before I grabbed the screen shot. Even if I move up to the 75db area, there is no data.

I had also clicked the GW button and even after about 15 minutes the progress bar had not even started to move.

These the ones you were looking for?
Thanks, James

See less See more
Huh, everything looks fine there.

You're one version back on Java. You might try and update that to the latest version. Just go to the Windows Control panel and open the Java console and update it.

You might also try to select the REW Settings pull-down and select Delete Settings and Shutdown. Then restart REW and try it. (you'll have to rebrowse to your cal files).


I updated to the lastest JRE right before I posted. Trying the other step now.

It is probably something I am doing. I have not used REW in so long it took me about 2 hours just to get some measurements taken:dizzy:


Something in those saved files must be messed up. I reinstalled REW and pulled up an old sweep and can get a waterfall, just not with anything made today.

OK good. At least it seems to be working now. I have no explanation for the problem....

Since no root cause was found for this, if you want to zap this theard that is fine by me.

I am having the same issue.

I have tried it on two different computers, XP and 7, latest java and v5.22 and the status bar never advances and I never get any calculated Spectral Decay or Waterfall plots.

I also reinstalled the 4.10 version on both machines with no go.

Any ideas?
I changed my measurement frequency from 120 to 130hz and waterfall works again, for some reason the waterfall function stopped working.
No go for me, I am not sure what else to try here. :(
Joe, I think I have seen weird behavior trying to create waterfall charts when some external noise during the measurement process, or some electrical noise in the signal, caused a glitch in the data. So you could try taking the measurements again, and see if you have the same problem.

You could also try using the Spectrum tab, setting the Mode to Spectrum instead of RTA, and take a real time measurement using pink noise to see if there are any obvious spikes at, say, harmonics of 60Hz. If you see these, some people with laptops have been able to fix these by taking measures on battery power instead of line power.


Along with the information Bill has above, do you by chance have a saved file from older traces you can load and see if the WF will generate?

I believe something must have corrupted the file(s) when I had my issue since older saved data would work.

Joe, here's another suggestion. Besides my unlikely suggestion of 60Hz harmonics, REW can get very confused if there is something like a static pop during the measurement. Unusually it figures this out and tells you it was a bad measurement. But this could also show up if you look at the Impulse graph. Does it look as if there were multiple peaks, equally loud? Or a later peak louder than the first? I wish I could make more specific suggestions, but I think I deleted the one or two measures where the Waterfall did not show anything. In my case, when I tried a second measure everything worked fine, so I discarded the first.

Good luck,
Thanks guys, I don't think there were any pops or anything like that.

I have taken many measurements (usually 5-80 Hz) it refuses to calculate for any of them.

No, unfortunately I don't have any older traces.
I will try reinstalling it again later tonight and taking more measurements.
Maybe I will get lucky.
I will also try the Spectrum tab, RTA deal too.
Fingers crossed.
So far I am striking out, its a real bummer.
I am baffled. I will see if I have a 3rd XP machine I can try.:dontknow:
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.