Home Theater Forum and Systems banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
pt47wxc43g---blue was out of place and wouldn't adjust after some internet browsing I ordered ics and replaced both--fixed the blue---now the red is unadjustable-----figured it was my solder job so I resoldered both ics----still no luck---I saw a resistor that was obviously bad so I replaced it-------so I ordered 2 more ics and replaced them again trying to be careful with the solder---(no adjustment on one suggested they were the problem--I don't know which one is red and which one is blue)

After the install--It powered up then down and blew a resistor--I replaced the resistor---now blu and red is ok---the green has a problem with only 2 of the 9 crosses used to adjust the convergence(seems warped or bowed)are out of place--if default convergence is used the red and blue end up on top of each other with the green in all but 2 of the crosses----there are 2 green crosses that are out from under where they should be and the entire picture looks somewhat bowed -

I'm into this about 60 bucks and am about to give up! Wife wants a new TV!:huh::huh::huh::huh::huh:
 

·
Plain ole user
Joined
·
11,121 Posts
Your post has been moved to a more appropriate location to make information easier to find and to make it more likely that others who are interested will find your post.
 

·
Plain ole user
Joined
·
11,121 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #4
mcm electronics for the ics and panasonic for the resistors---green does not adjust--maybe later I can get a pic of the set while it's in the convergence mode---thanks for the reply
 

·
Plain ole user
Joined
·
11,121 Posts
While MCM is a useful supplier, I would not trust their STKs. Use one of the suppliers suggested in the sticky and check all connections and resistors very carefully. The most common reason for repeat failures is missing something like a damaged trace, solder bridge, or open resistors.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
the first screen in the convergence menu is the green adjustment--2 marks on the cabinet that you line up with 2 green marks on screen---the horizonal wont adjust ---question is---is this a ic issue? I hope so--I assumed so and ordered ics for the third time------sanyo--this time-- I'm hoping!
 

·
Plain ole user
Joined
·
11,121 Posts
Usually it is a bad chip, but it could be a bad connection or open resistor. Check the continuity through the circuit on the green.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Replaced the ics again--sony this time----same problem. In checking the resistors I test 2 that are supposed to be 120 ohm--testing 85 so I have one replacement left and I test it prior to installation and it tests 85 ohms(panasonic erg2fj820h)-------now what?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Fixed! Saw a hack on the net describing similiar issues and the fix was getting into the service menu and tweakin the settings. Don't know exactly what I did to fix it but it worked! I'm thinking a couple of default settings were out of whack!

to get to the service menu----tune to channel 124 ---turn volume to 0--- set the antenna to cable--- and set the timer to 30----then try holding in on the volume button down---till "check" (in red letters) appears on the screen----mine was a little different but I managed to enter----then the sub menu was complex but I just entered each one and if offered a default setting accepted--if not--- then I just backed carefully out without adjusting the settings--hope this helps someone else!
 

·
Plain ole user
Joined
·
11,121 Posts
It should not be a matter of hacking. One should always get the service documentation on any set serviced, particularly for convergence issues. If you can't get into the service level convergence, you simply will not get the best results. Just changing parts is only part of the repair. Most people don't realize how much careful convergence can improve performance.
 
1 - 10 of 10 Posts
Top