Home Theater Forum and Systems banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys,

I’m new to this forum and was hoping to resolve some issues that I have with my recently purchased Denon AVR-1912.

I have the following set up in place.

- TV connected to amp via Composite Cable. Because when I connected the TV using HDMI cable from TV HDMI port to ARC port in the amp it didn’t work. I can’t find the TV manual, so therefore don’t know if my TV supports this or am I missing something. The TV is and 47’’ LG Scarlett model.

- PS3 connected to the amp via HDMI

- Jamo C803 book shelf speakers connected to the amp

Issues:

1. When I play a Blue Ray movie via PS3 I have to go up to at least –10 (minus 10) to get good volume. Range is -80 to +18 (minus 80 to plus 18). It sounds really good at 0.0 but there is not much margin left at this point until I am at maximum volume.

But when I play the PS3 games via PS3 or connect my iPod and play music. It sounds good at around -20. Is this normal?

I used the Audyssey feature to calibrate the speakers to the room.

2. When I connect the iPod from the front USB port, the amp takes ages to recognise a command from the remote. Such as changing tracks of going back to play list. It’s very slow and sluggish.

At times the song will change but on the amp display it still shows the last song. Sometimes it freezes and works after like 5 mins.

The amp was an ex-demo. Not sure if this is relevant. Also, it is under warranty.

Any help will be greatly appreciated.

Cheers
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
Hi guys,

Thanks for all the inputs.

I think I need to update the firmware for my Denon. We have a 3rd Gen Ipod. My guess is as someone mentioned it was an ex-demo model. It might be that the firmware is not updated.

Will try that and update you all.

Cheers
 
1 - 3 of 3 Posts
Top