Home Theater Forum and Systems banner

[DRC] My Mic Calibrationsfile is not accepted

2019 Views 3 Replies 2 Participants Last post by  tarsonis

I measured the drc correction and than I saw that my mic compensation wasn't executed. I thought roomeq would export the impulses with my mic calibration.
The file is specially made for my mic.

It is something with the format. I don't know. It looks different in the editor.

Here is mine.

The example that comes with drc and works.

I tried to change my file manuelly. What a mess. It took me near a hour....:wits-end: Hope for help.
1 - 4 of 4 Posts
I thought roomeq would export the impulses with my mic calibration.
The impulse response of REW is not created with the mic calibration file included. The cal file is added when the response graph is created. This allows the user to remove or add the cal file later using the IR Windows Apply button.

All that said, I then highly doubt that the cal file is added to the impulse response on Export. It would be the raw impulse file without cal file added.

John can certainly correct me on that if I'm incorrect.

Okay. RoomEQ works great and I don't really need the export with mic comp.. But than I need to know what is different to my mic calib. and the examples by DRC. So drc can execute the compensation for the impulses.
Soouu, I was lucky and google gave me a important information after several tries.

- Your cal file should use the fullstop (period) as its decimal separator. If e.g. you have an IBF (German) cal file, that will have commas, so you need to search&replace to change them all.
- The cal file shouldn't have any comment-lines at the top or end.
- DRC seems to need a "zero frequency" and a "Nyquist frequency" entry in the cal file. so e.g. if you look at the original ECM8000.txt, it has a line for 0Hz and 22050Hz. You should add these lines to your new cal file if necessary. Keep the same gain and phase values as the first, and the last, real entries respectively (so if your mic cal starts at 20Hz with "20 -1.23 4.56" you should have a line "0 -1.23 4.56" before that. And the same for the 22050Hz at the end of the file).
Hope this helps somebody. It would be useful for the future to have this option in roomeq.
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.