Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I'm getting ready to order my BFD but I wanted to check to see what people are getting now. Is everyone who orders their DSP1124 from a major source new been getting one with v1.4 firmware the past few months?

I'm wondering if it is at all an issue or should I try to see if anyone within driving distance has one I can have them verify or check out myself.

Thanks!!
 

·
Registered
Joined
·
16 Posts
Hi ,

I am not in US and I got mine and it is ver 1.0.
I am not sure if this version has any issues but this is my only choice.
If I am correct ver 1.3 had midi issues hence 1.4 is required.Any one know of issue with ver 1.0?


Puneet
 
1 - 3 of 3 Posts
Top