Home Theater Forum and Systems banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I hope this is not considered off topic, as it seemed the best forum to ask for assistance.

The front of my Energy 1 center speaker fell off, pulling all of the wiring loose. So I have 4 wires - blue, red, black and white - and 3 speakers (2 mid and 1 tweeter?) that need reconnecting.

The 2 midrange speakers are connected with a white wire, so I assume I will connect the white wire to either.

I would appreciate any knowledgeable advice!

TIA,
Bill
 

Attachments

·
Moderator
Joined
·
1,662 Posts
The 2 midrange speakers are connected with a white wire, so I assume I will connect the white wire to either.
Hi Bill,

That wire is the key, how on earth did it get disconnected completely??? It should be the "jumper" between the 2 mids, as they appear to be wired in series. So that wire should run from the - (negative) of one mid to the + (positive) of the other (hence the puzzle on how it would have come off, vs all the others which connect to XO board).
Your best bet is always to contact manufacturer for schematic, but.....
Most likely red/black is +/- for tweeter. White (from XO board) goes to either mid + (pick one, call it mid1), white jumper goes from that same mid1 - to other mid (call it 2) +, then blue connects to mid 2 -
First thing would be to connect red/black to tweeter and gently raise volume. Should here treble, no bass, not "dull" sound. Then hook up mids.
Good luck.

cheers
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Many thanks! I will proceed, and with proper caution.

I was unclear when I spoke of white wire connection between speakers, as it is intact.

Thanks,
Bill
 

·
Registered
Joined
·
1 Posts
This same thing has just happened to me with my Energy Take 1, center speaker. How did you wire yours to fix the issue?
 
1 - 5 of 5 Posts
Top