Home Theater Forum and Systems banner

1 - 12 of 12 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
For some reason I am having a of a time with feedback as soon as I connect the Galaxy CM-140 using Turtle Beach Amigo II USB sound card.

I have tried 2 different computers with same results.

I have Calibrated the Soundcard and the graph look good.

I go to Check levels and I can not even get to 75 db and feedback occurs.

I have been doing some reading and trying to figure this out but can't get pasted it.
 

·
Premium Member
Joined
·
1,923 Posts
What is happening exactly that you are describing as feedback? On any computer, you want to be sure that mic input playback is muted...
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
mic input playback is muted...
That's the problem, it's not giving me that option, it cannot
Be muted. I am running XP.

Pretty much all the external sound cards listed aren't
Manufactured anymore.

Is there an external sound card that's still in production
Today that definately works?
 

·
Premium Member
Joined
·
1,400 Posts


You're looking for something similar to the above picture ( ie; make sure that "Listen To This Device" is left un-checked ) .

The problem you may have is finding which tab "Turtle Beach" has placed this option into and what have they named it .

The "play-through/monitor" option will be there ( in some form ), you just have to find it .

:sn:
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
You're looking for something similar to the above picture ( ie; make sure that "Listen To This Device" is left un-checked ) .

The problem you may have is finding which tab "Turtle Beach" has placed this option into and what have they named it .

The "play-through/monitor" option will be there ( in some form ), you just have to find it .

:sn:
Thanks for the help, I have searched around XP and I cannot find any settings for that, I think the Turtle Beach Amigo II doesn't allow to adjust for that setting.
 

·
Premium Member
Joined
·
6,711 Posts
On the playback mixer settings ('Speaker') check under Options -> Preferences that all the available volume controls are selected for display, there can be an "Input Monitor" volume control that is not displayed unless you select it in the preferences:

prefs.jpg
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
That's the problem, I only have the first 4 options
You have checked, there is no other options in that
Window under TurtleBeach. Under the recorder settings
There is only mic.

It's definately the sound card options problem.
I have a SoundBlaster sound card on the way.

The Turtle Beach Audio Advantage Amigo II will definately
Not work.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #12 ·
Just to clear this thread up the TurtleBeach Audio Advantage Amigo II did not give me the option to mute the playback.

I purchased the SoundBlaster X-Fi Surround 5.1 Pro which did work fine. Just had to load their software and disable any surround modes and everything worked out great.

Thanks for all the help.
 
1 - 12 of 12 Posts
Top