Home Theater Forum and Systems banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
8,112 Posts
Discussion Starter #1
***I made this exact Post in the 93 Thread, but figured many might miss it and as this is a popular Title and no doubt also affects the BDP-95, I thought I would also start a dedicated Thread. The BD was just Released yesterday 9/9/11

Hello,
If anyone is having problems playing back X Men First Class, 20th Century Fox really are getting despotic. I picked up the BD today, got home and it would simply not Load. Even after waiting 20 Minutes, it would not play. I erased Persistent Storage, Turned off BD Live and updated to the latest Beta Firmware and got nowhere.

As this is the first BD or any Disc of any kind that would not play on my OPPO, I figured it was a poorly Authored Disc and went back to BB and went through the fun of waiting in line 15 Minutes to exchange it. I get Home and of course the BDP still reads 0:00:00.

I was too frustrated to go back to BB and started watching it on my PC when on a lark I disconnected the Wifi Dongle. As soon as I do so, the BD works perfectly. My jaw dropped as I use Ethernet and have the Wifi Connector there so I do not lose it. So if you have this issue with a 93 or 95 try taking out the Wifi Connector or Dongle.
Cheers,
JJ
 

·
Registered
Joined
·
1,660 Posts
Wow, "despotic", had to look that one up :scratch:

Very unusual issue and solution, Ill be curious to see if additional players are affected. Sorry for the issue, how was the movie?
 

·
Premium Member
Joined
·
8,112 Posts
Discussion Starter #3
Hello,
For a Tentpole Movie, it really is quite good thus far. I posted the Solution the moment I stumbled upon it so I am just about a quarter in so far. Fox really are the kings of requiring new Firmware and other fun stuff just to make their BDP'S play.
Cheers,
JJ
 

·
Banned
Joined
·
199 Posts
I just love ripping my BR titles to the computer w/o all that 2.0 profile junk. Thanks a lot Sony/Hollywood/U.S Government.
 
1 - 4 of 4 Posts
Top