Home Theater Forum and Systems banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a full Sony Sava 500 Speaker set up with a Creative receiver. My issue is the center speaker will not produce any sound. So basically all talking in movies and most games does not work. all other speakers work fine including sub woofers. the speaker itself is fine because i tried plugging it into the rear terminal and it made sound as if it was the rear. Any help would be great. I took the rear panel off and tried to check fuses and they all seem to be ok... So i'm lost for words at this point. Thanks!
 

·
Premium Member
Joined
·
3,777 Posts
Welcome to the Shack. It sounds like you have an incorrect setting on your receiver. Make sure it is set for Dolby 5.1 or whatever the sorround mode is on your receiver. Have fun. Dennis
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I tried the settings and when its on Surround everything works but the center. I even tried jacking up the center speaker sound. could it be possible something is burnt out inside or maybe not compatible with the creative receiver?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I think I made some progress. I have a creative decoder ddts-100 in order to use optical sound, because the receiver on the speakers doesn't have an optical input. but when I did a test tone on the receiver I got sound out of the center speaker. So Thats what makes me think maybe its in the creative unit?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top