Home Theater Forum and Systems banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I need help with a lcd tv. The model number is 42MF521D/37. It quit one day and wouldn't turn on, no picture, no sound. The led continuously flashed. Then one day I tried it and nothing worked not even the led. I looked it over and didn't see any blown fuses. I didn't have the test equipment to check the caps. so I took it to a local shop. They checked it out and said they had to replace some of the caps. I took it home and plugged it in and nothing. There now is no sound or picture. Now the led flashes 1 short flash, a short pause, 1 long dim flash, followed by 1 long bright flash. There isn't a pause between the dim and bright flash. Please help!
 

·
Plain ole user
Joined
·
11,121 Posts
Are you sure that this is a Mitsubishi? Looks more like a Philips or Funai model number.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Are you sure that this is a Mitsubishi? Looks more like a Philips or Funai model number.
Sorry about that I entered the wrong brand but have fixed the error. You are right its not a mitsubishi its a magnavox. I don't know what I was thinking when I typed that.
 

·
Plain ole user
Joined
·
11,121 Posts
Take it back to the shop, get them to fix it right. Get the details on the diagnosis and exactly what they did.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Tried tv today will turn on by using channel buttons on top of tv but not with power button on tv or with remote. Also remote won't control volume or anything. Tried 3 seperate remotes and nothing. Remotes will operate other tv in house but not this one.
 

·
Plain ole user
Joined
·
11,121 Posts
Could be a defective remote sensor, power supply problem, short on a data line...needs troubleshooting.
 

·
Registered
Joined
·
1 Posts
I'm having a similar issue with the same TV, nothing works. I pulled out the power board replace the fuse and plugged in the fuse popped and by looking at the circuit board this black square with 3 prongs coming off of it like a fork has a brown mark on the board. I think it is a voltage regulator. I solder the part out and took it to several electronic stores but there are no identify references on it that they can use. They state I need to know the components limitations before they can provide me a proper replacement. I don't know where to go get this information. I have searched several internet sites trying to find schematics and so forth. So I am desperate, can anyone assist me on this.

Thanks

Andrew
 

·
Plain ole user
Joined
·
11,121 Posts
You need a service manual to identify the part, using the location number from the circuit board, or the schematic locaton relative to connected parts. Once you know what it is you can find the proper replacement part. Do not assume that it simply failed. Depending on what it is and the related circuit, there may be more troubleshooting needed.
 
1 - 8 of 8 Posts
Top