Home Theater Forum and Systems banner

1 - 14 of 14 Posts

·
Registered
Joined
·
730 Posts
Discussion Starter #1 (Edited)
:scratchhead: I need help with my Samsung DLP hlr5067wax/xaa when i go to power it on and the only thing that happens on the front of the set is the lamp light flashes. if i look at the back of the tv i can see the lamp lighting up. after so long the standby light comes on flashing and the tv turns off. the screen stays black. I can press buttons on the remote and you can see it make the timer light on the front of the set flash but nothing comes on the screen. I had it all apart looking for bad solder joints. but didn't see any. I had issues with my samsung 43" dlp tv that it would turn off on it's own after being on for so long. I found bad solder joints in the power supply on that unit. The sad part is I just fixed the 43" last week and now this week my 50" tv dies.

I saw post that said about color wheel or the dmd. I dont hear the color wheel spinning but then again I can't hear it on my 43" ether. I had the Light Engine out. cleaned the fans put it back in and same issue. but i did see the about 1/4" of the glass on the lamp looks discollored on the one side. ( the front glass not the lamp itself.) my 43" tv's lamp isn't like that. is there a way to test the color wheel? I didn't even see it. do i have to take a cover off to see the color wheel?
 

·
Registered
Joined
·
730 Posts
Discussion Starter #2
I forgot to say that when I cleaned the DMD heatsink it was full of dirt and fuzz I dont think the fan was cooling it with how dirty it was. I bought this tv for 50 us dollars as is broken thinking I could repair it. I already had the DMD board removed looked at it and put everything back together. I am thinking it maybe the DMD board. but I thought I would ask some of you who know more about these sets. the guy I bought the tv from was told by a local repair shop they thought the light engine was bad maybe a chip, but couldn't say for sure unless they looked at it. the guy thought it wasn't worth repairing so he just bought another tv.
 

·
Plain ole user
Joined
·
11,121 Posts
Digital boards are common in these causing strange system control and shutdown problems.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #5
ok i found out what the digital board is. I just looked and the small fan on the digital board is not spinning. is it to spin all the time or only after it gets so warm? I see it plugs into the main system board and does not plug into the digital board.
 

·
Plain ole user
Joined
·
11,121 Posts
The digital board is not the DMD board. It is the lower board of the two on the right looking at the back of the set. It contains system control and all of the digital processing not local to the light engine. I do not recall if the fans run continously or are temp controlled.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #7
thank you. now I am looking for one of these boards and everyone is sold out. I see this model has a lot of issues like this. and other models that used the same boards have the same issue. I am surprized that samsung didn't have a recall on these tv's I called the guy I bought the tv from and he told me he had issues when the tv was about 3 months old that the screen would turn green and he called them and they told him to unplug the tv. he said every so often he had to unplug it and he called samsung about it many times. he also said the last time this happen the screen turned green he unplugged the tv and when he plugged it back in it wouldn't turn on the hole way.

board P/N: BP41-00237A from what I was looking up. looked like places used to have them for $69.99 new until they were sold out.
 

·
Plain ole user
Joined
·
11,121 Posts
I am not sure about that part number. It shows as NLA on the SamsungParts site. There is some confusion about what the correct number is and I am trying to get it clarified with Samsung. The number that I have is BP94-02084A which has just shipped after being BO'd for many weeks. I hope to have it next week and verify that it is the right board for these sets.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #9 (Edited)
thank you. it maybe an updated compatable board. but when i looked at partstore.com it doesn't list his model. It list model Samsung HLR5067WAXXAP. it maybe more then I am willing to pay. i am thinking that it maybe the PAL verson of the same board and not the NTSC. I looked up the model number HLR5067waxxap and I come up with webpages for over seas that I can't read. if it is the over seas model I wonder if there is any mods we could to to switch it to ntsc.

http://www.partstore.com/CompatibleModels/Samsung/Samsung/BP9402084A/New.aspx
 

·
Registered
Joined
·
730 Posts
Discussion Starter #11 (Edited)
ok it's the digital board. I took it apart and there is a chip that looks like a chip set by the dvi output that goes to the DMD board. I put a ball of foil over it and sqeezed the case back on. the tv powers up and the display comes on. I guess its something like the xbox 360 x clamp mode. ( maybe one of us could come up with a better fix for this. like a heat sink that will push down when the case is screwed back on ) It pushes the chip down and makes it get contact. just need to make sure the foil doesn't push down and short anything eles out. also I think i have messed up one of the ajustments. for the screen. my photo is up to high on the screen I could see this issue after i put it back together after having everything apart. I will take a photo to show what i did to make the board work and what my screen issue is now.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #12
this is what i get after doing that it seams the digital board now works but i must of messed up another setting or something when I removed the dmd.

ok you can see the black bar at the bottom and you can see the onscreen is up to high. what did I mess up earlyer. I saw the black bar a little bit when I had the tv on before after i took it apart before I could see the black screen was darker at the bottom.



 

·
Registered
Joined
·
730 Posts
Discussion Starter #13
I took it back apart and this time I didn't tighten the screws with the springs the hole way and it seems to be fine. but when its in the smaller sd mode and not screatched it looks to me a little off center but looks fine in streatched mode and in HDTV. I am not sure if that is normal for this set or if i need to do a little more ajusting.
 
1 - 14 of 14 Posts
Top