Home Theater Forum and Systems banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello and thanks in advance.

I've read through the relevant posts here, but wanted to provide my symptoms for any help in diagnosing.

Had my HL-5067W about 2.5 years now, not had any problems until we had a power outage at home about 3-4 weeks ago. I have it on a nice surge protector, but since then. I've had intermittent problems getting it powered on with symptoms becoming more frequent lately.

Here are the different things that happened when I turned it on many times tonight (not working initially):

Turn on - lamp blinks 17 or 18 times. No picture. Wheel and lamp on in back. Front LED lights up showing it's getting a remote commands, but no response. Eventually turns itself off.

Turn on - get picture but slightly choppy like it's dropping frames. No sound. LED lights up with remote commands but no response. After 1 minute picture goes black then after 30 seconds picture returns then after 30 seconds goes black then after 30 seconds picture returns with sound (still not responding to remote) then turns off (standby light comes on)

Turn on lamp blinks 17 or 18 times. No picture. Wheel and lamp on in back. Lights up with remote commands but no response. Picture suddenly appears after 2 minutes but freezes for 10 seconds then goes black. Turns off 40 seconds later.

Turn on - picture comes on right away, sound for 1 second then no sound, no remote response. Blacks out after 1.5 minutes.

Turn on works perfectly for long period of time (when it turns on good never had issue until next power-up.

Just noticed verticle section 2" wide on left of screen that is distorted (like glass block) when was working fine. Then went away and is 100% clear right now.

Other notes:
Color wheel sounds "normal" to me at all times.
Sometimes during blank/black screen will get quick flicker of white horizontally across parts of the screen.

Any help would be appreciated to know what to do next. I'm not inclined to put too much $$ into this set if a new 50"+ isn't too much more, but I'm happy to get my hands dirty if it might fix it.

Thanks,
Tito
 

·
Plain ole user
Joined
·
11,121 Posts
I have one of these that is very similar in symptoms and it appears to be the digital board. The one that I have on order is backordered now but there seems to be confusion about the part number. When I get clarification I will let you know.

The bar on the side sounds like a collapsing light tunnel.

Post the entire model. The service number on the back may have an additional suffix. This is very important with a sMsung set.
Posted via Mobile Device
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for the feedback diagnosing.

Here's the model info from the back panel. I'd appreciate any information to help me get to the estimated cost of the digital board to compare against replacement cost.

Model: HL-R5067W
Model Code: HLR5067WAX/XAA
Type No: AT50L6

Also today twice it came on fine and was responding to remote commands, but had no audio at all (would move the volume indicator and toggle mute, etc) and verified my sources have volume. One of the many varied ways this thing misbehaves right now. Ugh.

Tito
 

·
Plain ole user
Joined
·
11,121 Posts
Sounds a lot like mine. The digital board is on BO and I am still not sure about the part numbers. I will post when I get more info. I am pretty sure that the digital board is the problem because it actually came from another set that had shutdown and color problems. I used the board from my set to fix the client's set and now mine is squirrly. The other set works fine.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Thanks again for your help.

The only place I could find online to buy the digital board was discount-merchant but they're out of stock. Is this the right part and where you're looking? Is it in fact priced under $200? If it's $500 I'll probably go ahead and get a new set (ugh)

Assuming I can get my hands on a new digital board at a reasonable price, do I just need to buy a service manual from servicemanuals?

I can't access the service menu via Mute 182 Power despite trying much and wondered if there's anything I can diagnose further as our patience is going to run thin soon as it works very rarely now.

Thanks again!
 

·
Registered
Joined
·
730 Posts
I think i found a fix for the digital board please look at my new post. it worked for mine and my tv was doing the same as your tv.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
I have initial good news to report.

I just finished implementing the Dnite chip pressure hack/fix and have been 2 for 2 on successful power-ups since fixing. We'll see how consistent it is over time and I'll report back here.

Many thanks to Jason1976 and lcaillo who proposed and then refined this fix/hack. I took some pictures and plan to add to a post detailing the process of implementing the hack to help others determine if they want to go for it on their own. I also will include the Home Depot part info I used to craft my "pressure device" for under $3.

I've never done TV work before, just built a few simple PCs and found the process tedious and daunting at times, but in retospect not to difficult or prone to error. Definitely glad I tried it and hope this fixes the annoying issues that rendered my TV previously mostly broken.
 

·
Registered
Joined
·
730 Posts
I have initial good news to report.

I just finished implementing the Dnite chip pressure hack/fix and have been 2 for 2 on successful power-ups since fixing. We'll see how consistent it is over time and I'll report back here.

Many thanks to Jason1976 and lcaillo who proposed and then refined this fix/hack. I took some pictures and plan to add to a post detailing the process of implementing the hack to help others determine if they want to go for it on their own. I also will include the Home Depot part info I used to craft my "pressure device" for under $3.

I've never done TV work before, just built a few simple PCs and found the process tedious and daunting at times, but in retospect not to difficult or prone to error. Definitely glad I tried it and hope this fixes the annoying issues that rendered my TV previously mostly broken.
If it keeps on working 3 dollars is a lot less then buying a new digital board. I am glad it seams to be working. I am guessing we will save a lot of these tv's from ending up in land fills. The home depot part list would be helpful. I can't wait to see your photos.
 
1 - 11 of 11 Posts
Top