Home Theater Forum and Systems banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have just spent many hours reading posts on this forum and elsewhere on the internet hoping to find a solution but it resulted in no answers specific to my situation so here goes………

I am the original owner of this Samsung. Replaced a lamp w/ factory parts several years ago. Other than that never a problem. Recently the TV was on and I heard a “pop” sound, looked at the screen and it went dark. Turned the TV off, and then back on, and the screen never lit up. The “lamp” light is flashing on the front LED indicators……., I can hear the fan and color wheel spinning up. The chime sounds and then there is a momentary “buzzing” sound. After a brief time the same buzz sounds. The screen does not come on.

I replaced the lamp with a new one. No joy, same symptoms. While depressing the lamp cover switch and connecting power I observed the same sequence listed above. I noticed that during the buzzing noise the lamp is “sparking” as if it is trying to come on, but the lamp does not come on. I swapped the old lamp back in and observed the same except the old lamp only dimly “sparks”. The “lamp” light is flashing on the front LED indicators…….

This TV set is 8 or 9 years old so I can live with it dying, however, if there is a simple fix I am willing to spend a little…….

Thanks in advance for any help.

~Z~
 

·
Plain ole user
Joined
·
11,121 Posts
The sparking is normal. If the lamp does not start, you have a bad lamp or lamp ballast. It could be either, but if you have only changed the lamp once in the life of the set you are likely due for another.
 

·
Plain ole user
Joined
·
11,121 Posts
Where did you get the lamp? There are lots of cheap lamps sold as replacements that don't work. Lot's of people chase their tails with bad "new" lamps. Unfortunately the only way to test a lamp is with a known good ballast and power supply.
 
1 - 4 of 4 Posts
Top