Home Theater Forum and Systems banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all.

I am trying to set up a Roku Ultra in my system. Presently, the Audio is a very nice 2 channel system that I do not want to compromise.

I just purchased a Roku Ultra, and it seems pretty cool.

I use a projector that is fed by HDMI. I also have an Oppo BDP-83 that I want to continue to use.

I just picked up an Arcam Solo Movie 5.1 (old model) that seemed like a killer solution, except that it arrived damaged due to poor packing.

I liked the all in one of the Arcam, and it's low profile. It passes the HDMI, and switches between the Oppo and the Roku.

For audio, I used the optical out of the Roku into the Arcam. The Arcam main pre outs connected to the AV bypass on my 2 channel line stage.

For some reason, the surround channels are not working on the Arcam, but the center pre, the mains pres, and the sub pre outs are working.

I am looking for an elegant solution for all this.

I can get an HDMI switch for the video.

The Arcam solo movie 5.1 would have worked really well, if the surround channels would have worked. Maybe they were damaged? Maybe there is a setting somewhere that I am missing?

How to deal with the audio?

The solution needs to have analog outs for the main speakers so that I can not compromise or duplicate my 2 channel system.

I am looking for the least intrusive solution, but sound quality is an issue.

Any ideas?
 

·
Registered
Joined
·
2,074 Posts
Sorry Chris, I don't have any ideas for your problem, other than maybe disconnecting everything and starting fresh, which sometimes helps. I'm not familiar with the Arcam unit you're using, but are surround speakers enabled? If they're able to be set between large/small/off(?) that might be worth a look. Is it for all source material? Does the Arcam have an "all channel stereo" setting to see if you're getting any signal at all to the speakers?
 
1 - 2 of 2 Posts
Top