Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi,
I tried posting this in the forum on soundcards/soundblaster with Brucek but most of the posts are years old and no one seems to answer - so I am trying my luck here for a response.
Just spent the better part of 2 days trying to install soundblaster Live 24bit on Windows 7 OS 32b. Also read a gazzillion threads on this. Finally got the drivers from a Creative site but something is wrong as I dont get the Audio panel and options that I see in the various threads here - I get a very basic Audio Panel. I cannot get any output or calibrate my Radioshack SPL - so pretty down and out!
As a newbie I cant seem to upload the screenshots either - file size limitation and something about min 5 posts - sigh!.
So has anyone done the Soundblaster live/Win7deal - if so appreciate some assistance
cheers
BR
 

·
Premium Member
Joined
·
2,116 Posts
Hi,
I tried posting this in the forum on soundcards/soundblaster with Brucek but most of the posts are years old and no one seems to answer - so I am trying my luck here for a response.
Just spent the better part of 2 days trying to install soundblaster Live 24bit on Windows 7 OS 32b. Also read a gazzillion threads on this. Finally got the drivers from a Creative site but something is wrong as I dont get the Audio panel and options that I see in the various threads here - I get a very basic Audio Panel. I cannot get any output or calibrate my Radioshack SPL - so pretty down and out!
As a newbie I cant seem to upload the screenshots either - file size limitation and something about min 5 posts - sigh!.
So has anyone done the Soundblaster live/Win7deal - if so appreciate some assistance
cheers
BR
In Win7, if you right click on the speaker icon (bottom right) and pick Playback Devices, do you see it listed there?

It sounds like it might be missing some of the additional Soundblaster software - if you're looking for some additional features. If the drivers installed properly, you should see if listed in the Recording/Playback devices. Sometimes you have to manually enable the device.
 

·
Premium Member
Joined
·
17 Posts
Discussion Starter · #3 ·
It does appear as a listed device in Device Manager and the icon when you right click. But as you said, I suspect some software is missing therefore not enabling the full suite.
cheers
BR
 
1 - 3 of 3 Posts
Top