Home Theater Forum and Systems banner

1 - 7 of 7 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi, wondering if anyone can help...

I have an issue w/ my Mitsubishi. It turns on for about a second and then turns back off on its own. When he (my husband) presses Menu and input simultaneously it gets a 1-2 reading. Can anyone please help?

Thanks!

Christina
 

·
Plain ole user
Joined
·
11,121 Posts
Possibly bad front panel switches? Disconnect the connector going to the control panel and see if stays on when operated by remote.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #3
ok thanks.

i'll have my husband check that and see what happens.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #4
No, that's not it. We tried with the remote and it still turns back off.

When we turn the tv on the tubes turn on, we hear the power relay and then it turns back off.

We are definitley puzzled because it was working fine and then all of a sudden it just turned off...
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #5
ok, we are still getting a 1-2 error reading. when you unplug it from the wall to erase other codes when you plug it back in the wall the power light flashes three quick times.
 

·
Plain ole user
Joined
·
11,121 Posts
Did you disconnect the control panel before testing with the remote?
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #7
yes, we did and it set a 2-2 code when we tried that. then i unplugged it and plugged it back in an then it erased the 2-2 but then it reset the 1-2 error code .
 
1 - 7 of 7 Posts
Top