Home Theater Forum and Systems banner

1 - 4 of 4 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My Mitsubishi VS-50805 lost its picture a couple of days ago. Like other pictures I have seen posted, only the menu can be displayed but the image is distorted and convergence way off with no means of manual adjusting it. After reading several threads, I decided to dis-assemble the unit and look for possible CRT leaks. There is a leak from the Blue CRT with coolant still evident on the CRT frame. There is no visible air bubble in the CRT.

The coolant dripped from the CRT frame onto the main board between the jungle board and convergence IC's, apparent by a slick/clean look within the abundance of dust. I was not able to notice any corrosion with an inspection of the board (above or below), but I will do a complete cleaning nonetheless. However, I did find that both the R8E00 and R8E03 convergence resistors have smoked. Can I assume the convergence ICs are bad as well? What other items should be checked?

Thanks for the help.

Sean
 

·
Plain ole user
Joined
·
11,121 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #3
What I thought might be a coolant leak, I think was actually silicone from the heat sink grease. There is no evidence of any corrosion, just a greasy film. I did clean the board thoroughly, replaced the IC's and the output resistors and checked continuity on all the fuses. I re-assembled today and powered up. Now there is no picture and no OBD. The green LED is lit steady and I hear the power relay. Upon checking the fault codes, the "12" (No problem) is displayed.

I am going to dis-assemble and re-check all connections and power to the IC's. Any suggestions?

Thanks.
 

·
Plain ole user
Joined
·
11,121 Posts
Time to get out the scope and do some real troubleshooting. Sorry, no suggestions at this point other than that.
 
1 - 4 of 4 Posts
Top