Home Theater Forum and Systems banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a Mits WS-55511. Bought it new in 2003. Worked great until last week. Initially thought the cable box was going bad - saw a choppy signal to start. After I power cycled the TV and the cable box, I see a black screen with the following error message "Check connections or power. The connections for RGBHV or YPrPb may be invalid" The sound is OK, but no picture. I swapped out cable boxes. Same issue - no HD picture. When I bring signal from the cable box to another input, say Input 1, I have a good picture and good sound. Other devices connected other inputs seem to work fine when the input is not the DTV (1080) input.

So, I'm thinking the DTV input is bad. Then tonight, I happen to try a non HD channel through the DTV input (RGB) - lo and behold, I have picture (not hi-def) but no sound. If I change the channel from a low-def to a high-def channel, I get a few seconds of what appears to be a scrambled signal (which I used to get anyway), but instead of evolving to a nice, clean HD screen, I go to the error message ("Check connections or power....)

I've tried the hard reset, swapping cable boxes, changing RGB cables - no improvement.

Could there be an issue with my cable provider's HD signal?

This is definitely a different issue than the blinking lights of death....

Any ideas?

Thanks!
 

·
Plain ole user
Joined
·
11,121 Posts
Make sure that the box is not outputing 720p. The set only syncs to 480 and 1080i signals.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Is it possible the cable provider changed something? Our provider is Cox Cable and their HD broadcasts are reportedly 720. However, it was working just fine for 8 years..... Until two weeks ago.

Thanks for your help.
 

·
Plain ole user
Joined
·
11,121 Posts
Cox retransmits channels that are both 1080i and 720p here. Your box should display the resolution. If it is set to 720p that is your problem. If it is not the set likely has a problem.
 
1 - 4 of 4 Posts
Top