Home Theater Forum and Systems banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a mitsubishi hd 1080 with red and green shadows. I have read other threads on this site that have been very helpful in my efforts to troubleshoot this TV. My screen pinches in the middle and goes back to full screen at the edges with the colors not alligning as they should. My modle is WS-55809. Any advice and or help would be greatly appreiciated.
 

·
Plain ole user
Joined
·
11,121 Posts
Please do not double post. I responded to your other post in the other thread. I will delete that post and we can continue here. The thread name here will be changed to include the exact model number. If we do not keep the forums organized and concise, other users will be unlikely to benefit from the discussion and experience.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Sorry as you can tell I am very new at this and did not know the protocall. Just to clairify did you need me to change the name or will you do that so you get it in the proper format?
 

·
Plain ole user
Joined
·
11,121 Posts
Done. Just did not want to do it until you responded and knew what was going on. Everyone is new at some time and it is not a big deal. I have found that most forums are poorly managed and it is very hard to find information in them. We try to do better...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I understand,

I have read numerous posts and have a good understanding of the convergence output issues that the HD 1080 have. I already have plans to tip up the main board and touch up the solder connections on the output chips. From the description I submitted my screen seams to be different that that was described inwhat I read. Can you confirm that I am looking at the same issue and if the touching up does not work what chips I need to purchase.

Thanks
Ing
 

·
Plain ole user
Joined
·
11,121 Posts
Sounds like convergence but without seeing the set it is hard to tell.
 

·
Plain ole user
Joined
·
11,121 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Ok thanks for your patience I will touch up the solder connections and get back to you tomorrow. Thank you very much for your help.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
Thank you very much for your assistance. I reflowed the solder joints last night and the set is fixed. This has been a great experience and I cannot tell you how much I appreiciate the insight that this forum has provided.

Ing
 

·
Plain ole user
Joined
·
11,121 Posts
Be aware that the problem may come back and the chip may need to be replaced.
 
1 - 12 of 12 Posts
Top