Home Theater Forum and Systems banner

new audio formats

1505 Views 9 Replies 6 Participants Last post by  mattlarry
On several new-release BR rentals the center audio tracks are completely missing. If I use the "descriptive audio" it plays through (along with voice-overs) and it also plays in other languages. My BR is a 4 year old LG 390 with all firmware updates, and my receiver is an older Yamaha 663 setup as 5.1 with external sub and LCR amps. My first thought is that the BR player is not decoding newer audio coding, though it could be my receiver does not interpret the newly-decoded HDMI signals from the player. I recognize both may be at the end of their supportable life, but does anybody have insight on which needs to be upgraded...yes...I want to go with a new OPPO 103d...
1 - 10 of 10 Posts
Good Question Matt,

Honestly I am not sure but I suspect something.
May I ask how you have the player and the AVR connected ?
That does seem odd, Im still using a receiver from 2007 and its still playing everything I throw at it. Including DTS MA & TruHD 7.1 never had the center not work.
As Jack has asked how is the receiver connected?
Once my center channel stopped working and I thought the center channel had gone out on my AVR but it was just a loose connection. I think one of my toddlers at the time had knocked it loose.

Doesn't hurt to double check your connections.
Connections from BR and TIVO are via HDMI, and because the center channel works in other languages (via BR) and other discs, I know the connections are solid, as is the center amp channel. I am a bit shocked that LG wouldn't continue to release updates & support if that is the case.
Just to confirm, you are sending bistream from the player?
the player shows pcm multi-channel as the selected audio, and is set at 5.1 output (which is what my receiver and speakers are capable of)
Change it to bitstream and let the receiver do the decoding .
there is a pass-through option...I'll try that, however my receiver is older than my BR player...worth a try, thanks!
Change it to bitstream and let the receiver do the decoding .
I tried the same thing and it worked well.
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.