Home Theater Forum and Systems banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I was given a Philips 46pp930217 for free. The tv had bad coolant and a convergence problem. The tv is only 5 yrs old so I decided to put the work and parts in. I did the all the repairs, including soldering all the pins in the stk IC. Problem is now no letting will show up on the screen. I dont see any subtitles and the menu will not come up so I can reset the convergence. Can anyone give me a little direction.
 

·
Plain ole user
Joined
·
11,121 Posts
Could be a bad SSB (small signal board). Hard to know without doing some troubleshooting. Did it work before?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
yes the menu came up and there were subtitles when you muted it. Is it possible that a solder bridge could cause this.
 

·
Plain ole user
Joined
·
11,121 Posts
Or you pulled something loose. If it worked before and now it does not it is likely that you did something in repairing the set to cause it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
You were right one of the plugs was not seated all the way. I put it all the way down and now I have lettering. Problem is now my convergence is worse. I believe there is already multiple topics about that prob so I will take a look around before I start asking.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I got the writing back but now I dont have the crosshairs for the manual convergence. I checked every plug and they are all seated, I also checked the solder and dont appear to have any bridges.
 

·
Plain ole user
Joined
·
11,121 Posts
You may have damaged something with a partial connection. You may still have a problem with a connection that you missed. There is no way to be sure without a schematic and some troubleshooting.
 
1 - 7 of 7 Posts
Top