Home Theater Forum and Systems banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
3,374 Posts
Discussion Starter #1 (Edited)
I have searched but couldn't find an answer so I will ask you fine people. I cant seem to get the dip switches on my 2500 right. I need to set it up to run bridged mono. If I turn down channel 2 and turn up channel 1 then both channels light up but it doesn't seem to be any different then when it was set up in stereo mode. So if someone is running a single 4ohm sub in bridged mono could you tell me what your dip switches are set too. Mine are,LRRLLRRRRL......thanks.:scratch:
 

·
Registered
Joined
·
207 Posts
I suppose your talking about your Behringer EUROPOWER EP2500? Have you checked the manual? It is located here.
 

·
Premium Member
Joined
·
3,374 Posts
Discussion Starter #3
Ya, I did mean the behringer. I found out my problem anyway. I had one switch wrong. It seems that what it say's on the amp is different then the manual. Thanks.
 

·
Registered
Joined
·
207 Posts
Silly manufacturers. Good luck with your Behringer.
 

·
Premium Member
Joined
·
3,374 Posts
Discussion Starter #5
Alright one more question. What led is supposed to light up in bridge mode? Right now the channel 2 led lights almost constantly and the channel 1 led only lights when there is a hard hit of bass.
 

·
Registered
Joined
·
214 Posts
How loud is the fan on the 2500. I am curious about pro amps, but my components are right behind me in my room
 

·
Premium Member
Joined
·
3,374 Posts
Discussion Starter #7
1 - 7 of 7 Posts
Top