Home Theater Forum and Systems banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi there,
I have an Onkyo TX-NR609 and a Panasonic DMP-BDT310 blu-ray player. Everything worked fine. I moved home and appear to have changed something accidentally. Dolby TrueHD Blu-ray disc plays as Dolby D and DTS-Master Audio as DTS. Tried playing different disc's. Same result. Not sure the setting on the blu-ray player is incorrect or the Onkyo receiver. Please help anyone. Thanks.
 

·
Registered
Joined
·
179 Posts
Did you use the correct HDMI output?

"Panasonic gets around this problem by offering a pair of HDMI outputs on the DMP-BDT310. One carries 3D video to the TV and the other carries lossless DTS-HD MA or Dolby TrueHD to your 5.1-channel amplifier. This solution might, at first glance, appear clumsy, but it's actually incredibly useful."
 

·
Registered
Joined
·
134 Posts
The disc player should have an "Information" feature about the audio and video it is outputting... if the disc player is outputting DD or DTS only, you have to go through the menus and find the setting that enables "advanced" audio formats. The receiver may also have an information page in it somewhere that will tell you the input signal. Again, if the input is DD or DTS... problem is in the disc player. The Onkyo menus may also have a setting in there SOMEWHERE (under Audio perhaps or some other submenu involving what formats to accept). You will have to connect the disc player to the Onkyo with an HDMI cable for the higher quality audio to be usable. Also in the Onkyo somewhere is a menu that says what video input and what audio input to use for each source... make those both point to the disc player and lossless formats.
 

·
Registered
Joined
·
179 Posts
Here you go!

Font Material property Parallel Drawing Rectangle
 
  • Like
Reactions: RobKnapp

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Thank you Da Wiz and BP1Fanatic. Appreciated much. Yes the HDMI was connected wrong. So switched to Sub. The Sub cable goes to the Onkyo. The output from the Onkyo is connected to an HDMI splitter - one connected to the TV and the other to projector.

I then tried the settings as shown on the manual (page sent by BP1Fanatic) HDMI Audio Output is now "On". But I have not succeeded in getting the HDMI (SUB) Output Mode to "V.OFF". I set it but it goes back to "Normal". Of course, DTS-HD MA disc continues to be displayed as DTS and ditto Dolby TrueHD.

Should I be also looking at the Onkyo?

Grateful for the help.
 
1 - 5 of 5 Posts
Top