Home Theater Forum and Systems banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
I'd be very grateful if anyone could offer some advice. We have an Onkyo 7.1 HDMI AV receiver, which has been great. But this week, we switched it on to find that we had no television picture, just audio. DVD's work, but no television. antenna, HDMI cable and all other cables are connected. Digital box is working fine.
I have a feeling that it's just a setting, and if i press a button it will all miraculously appear again.. but i feel like i've pressed every button about 100 times.. :) My husband works away and won't be home for a week, and i have 2 children with tv withdrawals.. can anyone help?:dizzy:
Can't even get into settings, because it won't come up on screen.
Thanks!
Deb
 

·
Premium Member
Joined
·
15,054 Posts
There will be a button on the front that will say I believe "display" once you push the button the Onkyo should show "HDMI out on/off" or something like that. (I am asuming that your have it connected to the display with a HDMI cable)? you will need to turn it "on"
If that does not fix it try connecting the Svideo or Component video output of the receiver to the display and see if you get a picture then.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
thanks for your reply Tony. I'm assuming if the HDMI cable was the problem, we wouldn't be able to get a picture with DVD's? that's why i'm so confused - we're still able to watch dvds, just not tv. We've tried connecting different cables but no joy.
 

·
Registered
Joined
·
1 Posts
Slack husband here the reciever in question is a Onkyo SR606 bought new 1st August 2008. Has been working flawlesly until now...Love the thing

Cheers
 

·
Premium Member
Joined
·
15,054 Posts
Do you use the tuner in the TV to watch TV or are you using a PVR or other external tuner? If its external Its sounding like the output for the video has either gone bad or the settings in the user menu of the unit is outputting via composite, SVideo or component. You may need to check that.
 
1 - 5 of 5 Posts
Top