Home Theater Forum and Systems banner

21 - 22 of 22 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #21
Thanks bro i search alot ok here mixer out put should be 0db to amp i think if mixer out put is more than 0db like higher goes in red that is bad so what i do now i close the volume from my amps to 0 and i set up my mixer out put to level to 0db and than i goes up on my amp and i goes higher until i see cliping and i keep volume little lower where it starts cliping. because my speakers are only 1000 peak and 500 rms per side but my amp is 1600 watts per channel so it is good thing i think when it clips and i control it from lowering volume from amp or i think my speaker will fry. i think you need to match the speakers watts with your amp or your speakers should be realy good quality it will reduce the cliping or no cliping may be at all.Still learning and i have one question is ep4000 can run on 8 ohms too.thanks gill 154.
 

·
Registered
Joined
·
1 Posts
first i want to say hello to everyone here today is my first day i am happy to be here i read lot`s of thing here before becomes a member thanks guys you are great.
Here is my question about my ep 4000 i bought a month a and half a go iam running thease two speakers 500 rms each channel and peak power is 1000 watts each channel they are eap 215d make the problem is my clip light comes on i am running on stereo mode how to get all out of it without cliping light`s on i have 1 and 10 on for cliping i am running computer to mixer and mixer to ep amp and two speakers when i push little hard starts clip light flashing if i push more clip starts more solid red lights please loking for help from month search so many place please need help thanks guys in advanced gill 154
Ok I think you should reduce the volume on the laptop to 50 then you can increase the volume from your power amp you will get a better sound. Thanks.
 
21 - 22 of 22 Posts
Top