Home Theater Forum and Systems banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hallo
When using REW on my PC, often random windows are generated when I move the mouse. See attachment. I have REW 5.18, but the problem persisted when I updated to 5.19beta.
I have windows 10 on the PC.
Any idea what the cause is, and what I could do?
Thanks for the help
 

Attachments

·
REW Author
Joined
·
6,711 Posts
The cause is a disagreement between Java and the graphics card driver. If updating the driver doesn't fix it you can disable Java's use of hardware acceleration as explained here.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6 (Edited)
The cause is a disagreement between Java and the graphics card driver. If updating the driver doesn't fix it you can disable Java's use of hardware acceleration as explained here.
hallo John,
Thanks for the help. I saw the following instruction in the previous threads:

You could also try disabling Java's use of hardware acceleration by putting
-Dsun.java2d.d3d=false
in the roomeqwizard.vmoptions file in the REW program directory.

How to do this? I open the roomeqwizard.vmoptions file with notepad, and add the line. That was OK. When saving the file, a message came that access was denied.

Note: when I had the problem with the random windows, I had the latest Nvidia driver WHQL 378.49 and a GTX970 graphics card. REW was with JRE.
 

·
REW Author
Joined
·
6,711 Posts
Save the modified file to desktop or "My Documents"
Move it from its location to the Program File directory
You will get a UAC prompt to confirm that you want to do that
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
Save the modified file to desktop or "My Documents"
Move it from its location to the Program File directory
You will get a UAC prompt to confirm that you want to do that
Hallo John,
Beautiful! Now it works perfectly. Thanks a lot.
I understood that the Java and the graphics acceleration of the graphics driver did not like each other in such cases, and that this command line would disable that. Actually, I did not feel much difference in graphics speed. But maybe this is because I have a fast processor (i7-6700K 6.7GHz).
Thanks again for the very helpful solution and the fast response!
 
1 - 8 of 8 Posts
Top